Skip to main content

Model M2453 or M6411 / 300, 366, or 466 MHz G3 processor

65 Questions View all

turn on but no chime and black screen

hi everyone

I just bought an iBook G3 clamshell graphite firewire model m6411

it's in a very good condition, nothing is broken or so.

but when I turn it on it works but no chime at the beginning and a black screen

here is a video I took of the problem

I've red around in the forums with no lock

I've reset the PMU and it didn't solve it

I've tried it with and without the battery and it didn't solve it

I've replaced the Ram even tho the iBook dose not make any "beeps" at start but still no luck

any idea what might be the problem and is there anything to try doing?


Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Most Helpful Answer

Shine a flashlight on the screen at an angle and see if you can discern a desktop (inverter issue).

Was this answer helpful?

Score 1

1 Comment:

hi, I did that but I saw nothing :/


Add a comment

@iahmad101 looks like your G3 does not have any sign of life. Per manual, start off by doing/checking these things:


Computer won’t start up

1 Reset the power manager by pressing the reset button above the power button. Wait five seconds and press the power button. Note: Before continuing, make sure the reset button is not caught under the plastic of the top case.

2 Try known-good power adapter.

3 Remove battery.

4 Disconnect internal keyboard completely and try starting up the computer. If the computer starts up, replace keyboard.

5 Remove any additional RAM and AirPort Card.

6 Replace DC-in board

7 Replace logic board.

Stop before replacing the logic board. Let us know what you got after all the other steps. Use these guides iBook G3 Clamshell to work on it. I could imagine that after almost 20 years there may just be some minor issues with the boards coming at you.

Was this answer helpful?

Score 1


hi, i’ve tried all but 6 and 7 and no luck :(the power port is working fine that it’s charging the battery with no problem it might be a logic board but is there any way diagnose that?


post some pictures of your DC-in and logicboard with your question. Maybe we can identify any issues.


Add a comment

Add your answer

Ahmad Alfardan will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 13

All Time: 302