Skip to main content

A television game console produced by Sony Computer Entertainment, also known as PS4. First announced February 20, 2013 and released November 15, 2013.

1662 Questions View all

I cannot eject Discs

I have been on holiday for the past 2 weeks. I have come back, and I accidentally left my plugs on for my PlayStation. It has been powered on, and I don’t remember powering it down. I cannot currently eject the game that is currently in the disc tray, and the only way that I know how I can get it out is by taking the PlayStation apart, which I don’t really want to do. Is there any way around this?

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

2 Answers

Chosen Solution

This is a common issue that can be fixed quite easily by following the steps below;

Non-tear-down Repair

  1. Turn off your PS4 by holding the power button until the system shuts off completely.
  2. Unplug all of the cords that are connected to your PS4 from the system directly.
  3. Place the PS4 vertically. The disc usually gets stuck when the console is horizontally resting. Placing it vertically may help dislodge it.
  4. Wait about 30 minutes.
  5. Reconnect all of the cords.
  6. Boot into safe mode by holding the power button for 7 to 8 seconds.
  7. Cross your fingers. That's really it. The disc should hopefully eject now.

If this has not worked, there is also a way that may resolve this, but it does require a little bit of assembly;

Tear-down Repair (I can upload a guide if needed)

  1. Slide down the top cover.
  2. Peer down the side of the hard drives, and you should locate a Flathead screw/bolt.
  3. Tighten this screw until it has a bit more give than it previously did.
  4. Cross your fingers. This is a manual eject button, just in the form of a screw.

A software reinstall would also be a good step to take if this would be a preferred route that you would rather take.

Was this answer helpful?

Score 5


I will try this now and let you know how I get on.


I have just uploaded a guide on how to do the manual eject disc steps. :)


Add a comment

You may have tried this but have you tried pressing the select button when having the game selected in the PS4 menu? There is a eject disc option there if the eject button is not working.

Was this answer helpful?

Score 2
Add a comment

Add your answer

MobGuru will be eternally grateful.
View Statistics:

Past 24 Hours: 34

Past 7 Days: 126

Past 30 Days: 729

All Time: 23,693