Skip to main content

The March 2015 update of Apple's 11" MacBook Air features fifth generation Intel Core i5 and i7 processors, resulting in slightly increased performance and battery life.

136 Questions View all

MacBook not turning on anymore and no longer charging.

Last night I accidentally left my phone charging on my laptop overnight while the laptop itself was charging, and when I woke up and tried to turn the computer on, it refused to boot.

I have left it unplugged for a couple hours and when I plug it back in, the LED indicator stays on the solid green light, which leads to me believe it is not charging either.

I have tried resetting the SMC, opening it up and disconnecting the battery, and using a new charger.

If anyone knows of any possible fixes, I would greatly appreciate your help, thanks in advance.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Solid green usually means it’s fully charged on that Mac. Try unplugging the battery and plug in magsafe, the machine should spontaneously boot. If that works, try plugging battery back again, let’s see what happens to start with. Fact that you have had such issue with phone charging should not harm the Mac in any way, possibly just a coincidence.

Was this answer helpful?

Score 3


If it still doesn't work try turning it on with the trackpad cable disconnected. You may need to remove the battery to disconnect that cable if you have difficulties disconnecting it.


Just tried plugging in magsafe with the battery unplugged, and it still refuses to boot, but the LED is now amber.

Also I have left the computer unplugged for more than 24 hours now and it is still showing green while the battery is plugged in.

Another thing I just noticed is that the SMC reset only works with the battery unplugged, with the battery plugged in it stays green the whole time, but unplugged the LED cycles between amber an green like its supposed to.


Just tried turning it on with the trackpad disconnected, no luck.


Fact that the led is now amber without battery is normal for that logic board. It seems the problem is beyond that and would be inclined to rule out battery, charging and main power lines. Things that may go bad are quite many..try as @benjamen50 suggested disconnecting trackpad cable to rule out that and keyboard possible issues too, that's a good idea. If picture doesn't yet change a logic board in depth diagnostic would be required unfortunately.


Let's give this a try:

Disconnect the battery again and this time press and hold the power button for a good minute then with the battery still disconnected plug in the MagSafe that should do it. If you don't fully discharge the system before plugging in the MagSafe alone it won't reset. Did that work this time?


Show 4 more comments

Add a comment

Add your answer

Brian Balboa will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 111