Skip to main content

Model A1418 / Late 2012 / 2.7 & 2.9 GHz Core i5 or 3.1 GHz Core i7 Processor

156 Questions View all

Is this SSD compatible with my computer?

Hi there. I would just like to confirm that this particular SSD is compatible with my 21.5” late 2012 iMac before I buy it.

Kingston A400 SSD 120GB 240GB 480GB 2.5 inch SATA III HDD Hard Disk HD SSD Notebook PC 120 240 480 G Internal Solid State Drive

Thanks.

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

The SSD's specs: Kingston A400 SSD

by

Add a comment

MacBook Battery Fix Kits

Starting at $69.99

Buy Now

MacBook Battery Fix Kits

Starting at $69.99

Buy Now

1 Answer

Most Helpful Answer

From the basic specs it does appear to be a workable SSD replacing your current HDD. Its an older generation so its SMART services are limited and the I/O speed is not the greatest. Review this review Kingston-A400-240GB If you jump to this view you’ll see the better drives SSD BenchMarks. Personally I would stick with either Crucial or Samsung 2.5” SSD’s as they are more aggressive in supporting the newer version of SMART and have great performance. Yes, they will be a bit more but on the long haul are a better bet.

iFixit offers an upgrade kit with all of the needed supplies and tools! iMac Intel 21.5" (Late 2012-Mid 2017) SSD Upgrade Bundle and here’s the guide you’ll need to follow iMac Intel 21.5" EMC 2544 Hard Drive Replacement

iMac Intel 21.5" (Late 2012-Mid 2017) SSD Upgrade Bundle Image

Product

iMac Intel 21.5" (Late 2012-Mid 2017) SSD Upgrade Bundle

$134.99

Was this answer helpful?

Score 1

Comments:

thanks for this. i just checked compatibility on the Crucial website for a 250 SSD and it said it was incompatible. is this because apple dont officially allow you to upgrade the HD or is it actually incompatible? Obviously i want to be sure i buy a compatible drive!

by

I know iFixit has checked out the Crucial drive they offer so I would recommend you go with that one.

This gets into the version of SMART services the drive supports. You system needs the current version.

Then I guess you'll need to go with Samsung 860 EVO SSD.

by

Add a comment

Add your answer

Danny Grogan will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 24

All Time: 24