Mid 2010 Model A1278 / 2.4 or 2.66 GHz Core 2 Duo processor

825 Questions View all

I put in a new hard drive, upgraded the ram and new battery

I went to go power it up and all I got was a beeping noise like “beep,beep,beep,…………..beep,beep,beep………….” now nothing works. No power indicator, no noise, nothing on the screen. I put in the new hard drive because I was getting a folder with a ?Mark in it. Any suggestions? Could it be the logic board?

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

Sounds like a crash code. Did you copy all the data to the new hard drive?

by

I did not as I can not get it to power up at all now

by

Add a comment

Free shipping on all orders over $100 or containing a Pro Tech Toolkit!

Browse Our Store

3 Answers

Most Helpful Answer

The three beeps indicate a RAM issue. First try reseating your RAM. That failing, install your old RAM.

Now we need to find out if you have selected the correct RAM. So go to the followingg link and enter the serial number from the back of your machine. This will give us the correct machine and tell us the correct RAM.

Let us know both your machine and the exact RAM you bought.

https://www.coconut-flavour.com/coconutb...

Once we know what you have we can go to diagnostics.

Was this answer helpful?

Score 3

Comments:

Ok so ever since those few beeps. My lap top has been completely unresponsive. Almost like trying to run it with no battery in it. I clipped in the old ram. Put the old hard drive back in and nothing.... completely in responsive. It won’t charge, it won’t show battery indication on the side, nothing.

by

Please answer my questions about your machine and the RAM you bought.

Meanwhile, disconnect the battery from the logic board and the mag-safe adapter. Press and hold the power on button for ten seconds. Now reconnect the battery and mag-safe. You should get a spontaneous re-boot.

by

Ok that reboot worked. I also took apart all the connections and reinstalled them. Now everything works perfectly. Thank you

by

Have you tried the new components yet? Start with just one at a time.

by

Add a comment

Try checking the cables if properly inserted also check your RAM.

Was this answer helpful?

Score 0
Add a comment

Try a few things to eliminate the possible issues, firstly plug it in to the wall with no battery and power it on. If it turns on it is the battery's fault. Next, try putting in the old ram and powering on with the new battery, if it works, it is the rams fault, now use a hard drive duplicator and duplicate the old drive to the new one.

Was this answer helpful?

Score 0

Comments:

With the new systems we don't clone drives anymore as you lose the repair partition doing so. Many machines will run without the battery.

by

Add a comment

Add your answer

Glenn Whelan Jr will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 51