iPhone 4

Fourth generation iPhone. Repair is straightforward, but the front glass and LCD must be replaced as a unit. GSM / 8, 16, or 32 GB capacity / Model A1332 / Black and White.

3013 Questions View all

iPhone Stuck at DFU Mode

Hey friends, I need a help here.

These days, my iPhone's 4 GPS has gone, it was able to get location only by triangulation/wifi (blue dot was not pulsating in Maps app). After so many restores and hours with the phone in open places trying to find satellites signal, I realized it was a hardware problem. So, I get my courage and did the "oven trick" (put the iPhone's PCB (motherboard) in the oven for 7 minutes at 385F. This can fix possible solder joints). Bingo! GPS alive after months dead and iPhone workin' fine.

After a month without problem, the gadget starts to show the famous "white screen of death" (WSO) after the phone went to sleep state (screen became white when I pressed "power" or "home" button to wake it up). So, after restores, disassemblings and contacts cleans, I had the "great" idea to put it back in the oven (God knows the oven could fix this issue too...). Bad idea, now the iPhone is stuck in DFU mode. I tried to restore and didn't work, I keep gettin' "error 1600". Actually, iTunes shows the "preparing iPhone to restore" message (I got shsh saved since 4.1, so, I used Tinyumbrella), showing the server accepted the phone's request, but the restoration stops there. As I need the unlock (I live in Brazil), I can't directly update the firmware. I tried to update to a custom Sn0wbreeze current firmware (4.3.3) too, but iTunes shows the same error, even if I use iReb or Redsn0w to put it at pwned dfu mode.

So, the point is... did I brick my iPhone forever? I tried iRecovey too with no success (it says something like "invalid parameter"). Does somebody got any different idea? Even it involves complety disassemble the iPhone, I'll try it!

Thanks in advance!


It's been a while since the last time I post here! Well, sorry to say that guys, but the only solution I found was to change my phone to another one at Apple Store. I tried everything avaliable on internet, and nothing worked. But in my case, after some research, I discovered it was a hardware fault (more specific at the flash memory, the "oven trick" (as I said in the original post) burned the solder joints, making it unstable for a while and finally culminating in a unplugging of the flash memory from the mainboard). But my case was different from yours, there's an oven in the halfway that bricked the phone. But, if the problem persist even a restore, there are strong clues that's a hardware fault. So, don't worry your head too much: go to a store and change your phone!

Answer this question I have this problem too

Is this a good question?

Score 0


did you found any solution for this? im on the same situation...

by DritonB

Add a comment

6 Answers

Most Helpful Answer

If you are using a Custom Firmware (Snowbreeze is great) at 4.3.3 you must have the SHSH for 4.3.3 on your computer, if you want to use TinyUmbrella Server. SHSH for current firmware is easy to get as Apple will still send it to you. You can also let Apple Sign the current firmware instead if you want, but you will have to use TinyUmbrella Advanced Settings to Remove check mark regarding Cydia, because this is Blocking Apple from signing firmware or even sending SHSH to your computer.

The reason for the 1600 Error is that your iPhone is not truly in Pwned DFU Mode. Try again using those tools that put it into true Pwned DFU.

Also be certain you are using Sn0wbreeze 2.7.3 to create the Custom 4.3.3 IPSW, and make sure you let it put your iPhone into Pwned DFU.

Was this answer helpful?

Score 1


Hey, Brad, thanks for answering!

Actually, I tried these steps, even asked my syster to lend her computer and installed iTunes on it to try a clear restore without any Tinyumbrella vestige (even knowing i'd lost my unlock, at least there was a chance of the phone come back to life), but it didn't work too.

My guess is that the oven really damaged the boot chip, or something related. When I try the restore, iTunes verify the restoration and accept it (with or without Tinyumbrella), but the "Error 1600" message shows up soon after the "preparing iPhone to restore" procedure. What seens is, despite iReb or Redsn0w confirm the Pwned DFU, the phone isn't really goes to that state, as I can't even see a single flash in the screen. My other think is that the phone goes to Pwned DFU, but for a hardware reason is unable to reboot (I tried jailbreak it and Redsn0w always stuck at "waiting for reboot"), making impossible any restoration attempt. The iPhone keeps inert, not a single sign at the screen that's something is goin' on inside.

Thank you so much for the help, but I guess my phone is really bricked. Maybe I shoulda try to find some hardware related workaround, but I'm not sure if that's possible.

by pois0m

Add a comment

Hi, there,

My problem is I have 2x iPhone 4 and just after trying to upgrade them to they never ever get out of DFU mode, even when using the original firmware.

I have tried every resource there is on internet,

one of the Iphones is on 4.0.1 firmware and on an old base band, so I don't want to try to upgrade it to the last 4.3.5, I also have disconnected the battery so it will reset. on new windows, on mac. I have used old iTunes, old redsn0w versions, greenpois0n, just about everything.

it even updates and itunes dn't give any error, then

it kicks in DFU again. #$%^#$%^#$%^#$%^#$%^#$%^#$%^

Please, Is there someone with the same problem that has an answer for me?

Thanks a lot.


Was this answer helpful?

Score 0
Add a comment

Try to use Custom Firmware created by sn0wbreeze-v2.7.3 at 4.3.3 and select Simple Bb

Use redsn0w for the DFU and restore with shift on iTunes good luck

Was this answer helpful?

Score 0
Add a comment

Eu tbm estou parado nesse modo :(

E eu fui burro o suficiente de esquecer de usar o tiny umbrela! e agora nem voltar atras eu consigo

eu fui tentar atualizar para 5.0.1 preservando a minha bb mas na hora de sicronizar com o itunes da o erro 1600 ou o 1604

alguma sugestão do que eu possa fazer? preciso de saber disso urgente!

(se for possivel responder no meu email, ele é matheusvf123@hotmail.com)

Was this answer helpful?

Score 0
Add a comment

This topic is old but problem still occur (for me with touch 4g). Only method to get out from dfu is to leave device under charger for more than 24h w/o touching - it will reboot into normal dfu automaticly.

Was this answer helpful?

Score 0
Add a comment

all you haved to do is hold down the power button on your device and your home button for about ten seconds and it should unbrick

Was this answer helpful?

Score 0
Add a comment

Add your answer

pois0m will be eternally grateful.

View Statistics:

Past 24 Hours: 0

Past 7 Days: 12

Past 30 Days: 32

All Time: 16,743