Skip to main content

2.2 GHz (Turbo Boost up to 3.4 GHz) or 2.5 GHz (Turbo Boost up to 3.7 GHz) quad-core Intel Core i7 processor with 6MB shared L3 cache.

265 Questions View all

MacBook Pro not turning on. (No chime, no fans)

I recently applied fresh thermal paste to the CPU and GPU and also installed an 970 EVO SSD to my Macbook Pro (A1398). It worked perfectly for two days and I was switching back and forth between the new SSD and the old SSD to backup and restore certain data.

And today it suddenly won't turn on (Merry Christmas!). When I try to turn it on, there is no chime, no backlight, no fans noise, and no illumination on keyboard/caps lock. When I plug the Magsafe charger in, charging indicator lights up green. And when I plug in an external HDD through the USB port and attempt to turn Macbook on, the external HDD makes spinning sound as if it was plugged in to a working computer. The sound continues until I force shut down the Macbook. However, a strange thing I noticed was if I turned the Macbook on with external HDD but without the charger plugged in, the external HDD makes those spinning sound for only 5 secs and then stops as Macbook apparently shuts itself off.

I tried the ‘spontaneous boot' that was suggested: Macbook was completely unresponsive. However I do not believe the logic board is fried as I can SMC reset and see the charging light go from amber to green. Also tried power cycles with original SSD, with new SSD and without any SSD: no luck. Tried powering it on with batteries attached/detached, tried with charger attached/detached and possible combinations of them: nothing.

I should also note that I'm not completely ruling out the possibility of liquid damage as I spilled a teaspoon amount of Isoprapanol to the logic board while cleaning off the old thermal paste. However I cleaned the spill immediately and Macbook worked perfectly fine for two days after that.

Does anyone have any idea what could be the issue here? Or at least what issues can I rule out given the above observations? Would really appreciate any sort of feedback or advice from this forum.

Thanks!

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Hello , the 970 EVO SSD you installed may be the problem. Does it have same power rating as your original hard drive that came with your machine?

Also, the thermal paste you used, was it ‘conductive’ or ‘non conductive’?

If it was ‘conductive’, you may have shorted something out on the board as the paste oozes out on reassembly.

The isopraponal you spilled would have evaporated, and all should be ok there if no power was on the machine at the time.

Was this answer helpful?

Score 0

Comments:

Thank you very much for your answer Chaz. The problem was fixed after letting a repair service take a look at my laptop. Apparently I toasted a chip while fiddling with the laptop. Still have no idea how. But it has been working perfectly with 970EVO since the repair.

by

Add a comment

Add your answer

Alex James will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 29