Skip to main content

Released in 1999, successor to the original PowerMac G3, 300-450 MHz, 64 or 128 MB of RAM, 6 or 12 GB HDD

18 Questions View all

This one is a doozie...

I wanted to see if I could run a very early version of Linux on this Mac, so I got an installation disk for Linux. I tried to boot from the disk, to my surprise nothing was showing up on the TV that the Power Mac was connected to. No grey screen, no boot menu, nothing, even though everything else appeared to be operating fine inside the Power Mac.

Here’s what the diagnostic LEDs are showing inside the Power Mac.

Did I brick my machine by trying to boot from this installation disk? Did my graphics Card die?

Things I I have ruled out:

  • The VGA cable is fine, I tested it with my Mac mini and it worked.

TL;DR: Screen is black, but startup chime is present, fan is running, and 2 LEDs are lit after trying to boot from a linux installation disk.

@mayer ideas?

Update (11/03/2018)

Is this the CUDA button I am looking for? I cannot distinguish between them. Tried pushing both of them, the one on the right made the Mac power on and off, the other one on the left made the Mac do the boot chime and made the optical drive rev up. Still no dice when it comes to the display, there’s nothing being shown. No flashing folder, no grey screen, nothing.

Block Image

I removed the PRAM battery for 30+ min and that didn’t help either.


Update (11/05/2018)

CUDA button was a no-go. I left the PRAM battery out for a full day now, thats a no-go too. Boots up, fans are running, optical drive operates, but no video. One thing I have noticed is before this incident happened, on boot up ALL of the LED’s on the logic board either stayed lit or blinked after booting up. After the linux incident only 2 of the 4 LED’s stay lit after the initial boot up. Could this be a sign?

I am leaning towards a graphics card issue. I just don’t want to be pouring money into unnecessary places.

Update (11/08/2018)

I am afraid that this machine is a brick now. I'll try a new GFX card as a last resort.

Update (11/14/2018)

A new Graphics Card didn’t work. This machine is officially a brick.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

3 Answers

Chosen Solution

Linux requires an Intel processor. Yours has a Motorola and will only run an Apple OS. Hang on I’ll find out which. If you don’t have it, email me your address and I’ll burn an installation disk for you and ship it. Then tell me what other types of software you want and I’ll - never mind, I have it all, it’s just a matter of dragging it out.

Pre-Installed MacOS:8.5.1, 8.6*Maximum MacOS:X 10.4.11

MacOS 9 Support:Boot/Classic ModeWindows Support:Emulation Only

Details:All Power Macintosh G3 models are capable of booting Mac OS 9 and using Mac OS 9 applications within the Mac OS X "Classic" environment.

350 MHz PowerPC 750 (G3) processor with 1 MB of backside cache, 64 MB or 128 MB of RAM, a 6 GB or 12 GB Ultra ATA/33 hard drive, a 32X CD-ROM drive or a 5X DVD-ROM drive, and an ATI Rage 128 GL graphics card with 16 MB of SDRAM.

Was this answer helpful?

Score 5


@mayer Check your inbox, theres an email from me on its way. Unfortunately, this disc seems to have ruined my Mac. However, the GFX card could have possibly crapped out coincidentally. I tried to do a PRAM reset but I could not get it to work.


See if there is a CUDA button on the logic board to reset it. Pull the battery so it looses it's mind and memory of the insult of the linux trauma you subjected it to.


I just saw your video and the CUDA button is grey and located just to the upper right hand corner of the heat sink.


@mayer Take a look at this website, it’s showing something different then what you said. The system powers on fine, the only thing thhats wrong here is that there’s no video. I have a hunch that the GFX Card is kaput.


@unsubstantiated It's considered polite to say why when you down vote an answer.


Show 10 more comments

Add a comment

Did a new graphics card work? That would be my guess as to why your Mac won’t display anything but appears to run fine.

Other then that, I think your Mac might be “bricked”. Incompatible installation discs tend to ruin PowerPC computers and that might be what happened here. Sorry bud.

Was this answer helpful?

Score 2

1 Comment:

Yes, I have tried a new graphics card and it is a no-go. I am considering doing a case mod with the outer shell. Frustrating!


Add a comment

One simple answer, apple did not configure their products to run Linux too. If you teardown a pc made to run Linux and an apple pc, you will find the basic parts the same but many supplementary parts too that the PC made to run Linux needed that the apple pc had.

Was this answer helpful?

Score 0


@luckytechguys I get that, I was just curious if I could boot from that drive. As soon as I put the installation disk in the optical drive all of this nonsense happened. Screen is black, but boot tone is present, optical drive operates, fan is running, and 2 LEDs are lit.

This isn't helpful at all, and it is somewhat off topic, sorry.


No problem, try booting on apple os and seeing if the PC is still working. If it is then you know Linux will not boot. If not, booting on linux screwed with the computer too.


Before this issue occurred I was able to power on the Mac and have it at least get to the flashing folder icon. My hard drive died on this computer and I don't have a drive. All I know is that this computer was running just fine before trying to boot from this installation media.


another recommendation, see the system requirements for the Linux version that you are trying to run. Compare them against your hardware. If the PC doesn't support the required system hardware, Linux will not boot. If this is the problem find a version compatible with all of the system specs you have.


and what was the version of linux you were trying to run?


Show 12 more comments

Add a comment

Add your answer

[deleted] will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 23

All Time: 1,261