Repair and troubleshooting information for the Suzuki FA50 Moped.

70 Questions View all

30 years without using

Got a Suzuki FA50 30 years ago, put 900 miles on it and storaged. Few days ago took it out got a new battery put some gas but it wont start.

Any idea?

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

3 Answers

Chosen Solution

Disassemble and clean the carburetor. Check careful for damaged gaskets and clogged jets. Also see if the engine cranks over cleanly. If in doubt, take it apart and give everything a thorough inspection and cleanout. Missing gakets you can easily make yourself with heavy paper and a 2 stroke engine is rather straightforward to strip and rebuild.

Was this answer helpful?

Score 5

Comments:

Works for me. +

by

Add a comment

New Plug and possible wiring could become an issue as well. check to make sure that you have spark. Take the plug out and crank it over while holding the plug against the cylinder head. It should give you a spark. Make sure of course that you do not hold it with your bare hands, could be shocking experience. Just got the parts list as well as the complete service manual so do feel free to download it. I do hope you get it fixed and let us know about it. Good Luck

Was this answer helpful?

Score 3
Add a comment

Just same here,30 years old and onused brandnew 1984 FA-50.

Put a bit gas in the tank with 2% oil ,kick two times and he runs as the fire brigade (smoke included).

Gonna do a total check and replace all fluids before i use him.

Ignition switch is missing ,look at ebay ,real rare (price also!).

Gonna look further (cheaper ,anybody knows????)

I'ts a shiny beaty :-)

Was this answer helpful?

Score 1
Add a comment

Add your answer

Oswaldo will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 4

All Time: 2,570