Unit went off after battery discharged.

First the Battery Icon in the top bar said BATTERY NOT CHARGING.

The machine continued to work until the battery ran down. This was during the ADAPTER being PLUGGED IN.

The Adapter connector showed ORANGE but not charging battery.

Replaced with different battery and unit booted up and ran until that battery went down.

Now not having the means of charging the battery and the machine not working from Adapter it is out of use.

I have replaced the smal DC board where the power adapter plugs in.

Then when connected to Adapter the light was green, orange and then briefly RED before it went off. That adapter still works with my other PB.

So question is...

What could trhe matter be and what cost would be involved for the part(s)?

Other than this the machine is perfect with a recent Apple replaced Screen (due white blotches and under Apple CAre)...

sincerely,

David

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Black Friday
Broken doesn't stand a chance.

4 Answers

Chosen Solution

If I remember correctly the dc-in board in that model connects directly to the logic board. If a recheck of the connection proves solid I would suspect a logic board problem. Before I invested in a logic board I'd make an appointment with the genius bar and confirm the logic board is bad, Ralph

Was this answer helpful?

Score 1
Add a comment

This may be a stupid question, but have you tried a different adapter?

Replacing the DC-in board would have been my next suggestion, but you already did that. At that point, it's starting to look like a logic board issue. We sell the logic board for $600, but are currently out of stock. You could put yourself on the notify list for the part (see link), or search Google with Apple part number 661-3765.

Good luck!

Was this answer helpful?

Score 1
Add a comment

Same problem here with mine, light stays orange, battery not charging.

Just wondering if on the 1.67mhz, if the multi-ribbon connector between the DC-in and the logic board could cause this problem? Regards

Was this answer helpful?

Score 0
Add a comment

I have the exact same symptoms.

Latest advice is maybe PMU Chip needs reset by holding down Power button 5 seconds. I have not tried that yet.

Also the ribbon leads are so small maybe as suggested there could be a failed connect.

It was the brief RED Diode at the power connector that interested me, I had the same coupled with a brief 'squeal' from inside.

After my last battery went flat then I have been unable to start up the machine.

Do you have any update on the issue?

Dave

Was this answer helpful?

Score 0
Add a comment

Add your answer

David will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 1,455