iMac dv won't complete startup

After attempting to install updates i believe 10.2.4, it required a reboot but system just gets to the Apple logo screen and the timer wheel keeps spinning. I have left it in this state for hours never completes. I have tried all sorts of key start-up combinations: s, command-s, shift, cmd+shift+del+opt, v, spacebar, cmd+opt+o+f. never gets past apple logo.

i don't have OS disks. any ideas would be welcome.

thanks in advance.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

If OSX is installed, restart the iMac while holding down Command S. When the text page appears,

Type: fsck -fy then press RETURN key (NB: there's a space between k and -).

You'll have to wait a little while the installed OS is scanned and repaired. When the repair is done you should read "The volume <<hard drive name >> appears to be OK" If you see "File system has been modified" retry the procedure (fsck -fy) until you see "The volume <<hard drive name >> appears to be OK" then type reboot and hit RETURN. The iMac should restart and boot a repaired system.

Was this answer helpful?

Score 0

Comments:

I have tried multiple holding keys at power-on each combination for about 25-30 minutes each try until my fingers cramped. i actually put a weight on the shift key and let that go for a few hours. All with same result. Apple logo screen appears, hard drive crunches and the little wheel spins and never gets to text display or desktop. thanks for the suggestion. i may have to buy a copy of osx tiger or try a ubuntu boot disk and try repairing from within ubuntu.

by

Add a comment

Add your answer

ronf57 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 3

All Time: 529