How do I troubleshoot Logic Board?

Here is a brief history of my issue: One day after moving my laptop to a remote recording location, I returned home to find it unable to boot. The front LED would turn on, the drive would sound like it was booting and then it would turn off. When holding the button in, the light would blink for a few seconds. I took it to the Apple Store. They said it was probably the logic board. I asked why it would decide to just fail completely out of nowhere. He had no answer. I came home that night... tried to boot again for fun... and funny thing, it booted perfectly. Few weeks later the same issue happend. Kept trying it and it worked. Eventually it stopped.

There is no logical explanation for my logic board to fail. I'm able to charge my battery and get a solid green light on my adapter. I've tried reseating the RAM, PRAM, SMC, etc. etc.

I found "lemerise"'s very helpful tips about jumping the power pads to troubleshoot the top case. I removed the airport card, hard drive, optical drive and data cable and tried this. When I plugged in the power, the light was very very faint green. When I jumped the power pads it started blinking green and amber. I'm just curious as to what this means and where to go next? Why do I get a solid green light when the case is on but not when its removed? Any advice short of "take it to teh apple store lol buy apple care" would be greatly appreciated.

Answered! View the answer I have this problem too

Is this a good question?

Score 1


Did you take out the I/O board? I've had the green/orange blinking before, but it was while testing an I/O board that wasn't seated correctly and shorting.


Not sure what I did but I got rid of the blinking amber light. Now when I jump the pads I can see the fans starting up and when the optical drive is in it makes a sound but then the fans stop. So it doesn't look like the top case is the issue unfortunately. I guess thats the end of the line...


Actually I was just getting that light because I don't think I was jumping it properly. I just would really like to know as technical an explanation as anyone can offer how my board is "dead" when its definitely trying to power up..its acting like its just losing power before it can fully boot. It can still charge a battery...the front LED and fans still work


I found that when I disconnect the Express Card port I get no light on the indicator on the power adapter. It also fails to even do the fake "start up." Is this normal? Also could the fans be a culprit?


Hi guys, I just found this awesome website, and came across this conversation. This is EXACTLY the problem I am having with my mac, Same model and everything (A1260) Same symptoms. Mark I was hoping that you could tell me exactly what you did to yours so that I could try it?? I've been trying to do what mayer and abcellers as well, but so far no luck. Have you been able to find out what it was?? Left I/O board or cable, magport connection (my adapter is 6mo. old), battey cable or connection? I would greatly appriciate the help guys. Sorry if I did this wrong, like I said I just found this site, and I like it alot. I just don't know how to use it yet. Anyways thanks in advance. And again same exact symptoms as mark.

Thanks, Zack


Show 4 more comments

Add a comment

1 Answer

Chosen Solution

This is a bit of a long shot but just might do it. This is the Mac Pro that I use for a personal machine. If my battery drains all the way down it will not start till it has about 30 minutes of charge even with the MagSafe adapter plugged in. I can hit the power button and walk away and in 20 to 30 minutes come back and it will have booted. So try giving it a good charge, and then try it. You might want to download and run Coconut battery to get a better idea of the condition of your battery.

Was this answer helpful?

Score 5


Take a look at the pins on your MagSafe. Use a toothpick to move them in and out, you may have one sticking thus not making contact with the DC IN board.


BOOM! Not sure if this was a combination of your advice and ABCellars but after jiggling my adapter and following ABCedars advice...I successfully just booted up for the first time in months. I'm almost too scared to even move anything. I'm wondering if its a problem with the magsafe port because when I took it into the apple store, they used their own adapter and it still failed. Cannot thank you enough. Not sure where to go from here..I'll inspect the port on the laptop?


Current charge: 1203 mAh. Maximum charge: 2141 mAh. 56%

Current capacity: 2141 mAh. Design capacity 5600 mAh 38%

Mac model: MacBookPro4,1.

Age of your Mac: 30 Months.

Loadcycles: 204

Battery Temp: 29.9c


This is also the first time having my battery in in a few months. I left it out to discharge the capacitors in the board and the battery still had some charge


Look at the MagSafe adapter and use a toothpick to move the pins in and out. Test with a multimeter. Here's the pin out on the right:

If your readings are good then replace the left I/O board. Please give us the last three letters of your serial number so we can get you to the correct part.


I cannot thank you enough. I was seconds away from scrapping it and buying a new Macbook or even worse, paying for a logic board replacement that wasn't necessary. I'm going to test the pins with a multimeter tomorrow, the one I have with me is too big. Though I bet it is probably the board. My serial number is RM8404EJYJX. It's weird that it wouldn't boot up straight from the battery though?


Show 8 more comments

Add a comment

Add your answer

nah will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 12

All Time: 5,154