Skip to main content

Fix Your Stuff

Right to Repair


Model A1312 / Mid 2011 / 2.7 & 3.1 GHz Core i5 or 3.4 GHz Core i7 Processor, ID iMac12,2

669 Questions View all

Persistent kernel panics (even in Safe Mode, disks not the cause)

I acquired this Mac second hand and am trying to repair it, and am faced with persistent kernel panics, but in circumstances that are not quite similar to other posts about the topic.

What happens booting normally?

Start up sound is normal. Fans start. Apple logo appears. Start up progress bar advances just over half. Screen flicks through black to all grey, and nothing further happens.

What happens if booting from an external hard disk, or USB stick?

Exactly the same - bar advances, then screen goes grey. I also disconnected the internal hard disk altogether and this made no difference - still impossible to boot from any other device. I am pretty sure drives are not causing this.

What about other peripherals?

All are disconnected. I have even tried this with no keyboard and mouse connected, and still the same.

What happens when booting into Safe Mode?

Kernel panic text appears above the grey screen, with the Apple and start of the start up progress bar still showing (full text of the kernel panic below)

Block Image

NOTE: this pic says CPU 2. Sometimes the Kernel Panic says CPU 3 in all instances too.

What happens when booting into Single User Mode?

Shown here (I am not keen to type all this up! But there is no way for me to recover it as text!)

Is the last line significant?

  • [IOBluetoothHCIController][SearchForTransportEventTimeOutHandler] -- Missing Bluetooth Controller Transport!

Block Image

In light of that line I disconnected the Bluetooth card and that too made no difference.

What about Apple Hardware Test?

Passes all tests. No errors found.

What about diagnostic LEDs on the logicboard?

All four of them illuminated.

What about memory?

I have read that RAM that is wrongly seated, or has degraded, can cause this. I even bought an extra SODIMM and took all other memory out of the machine and that did not solve it.

What about the SMC and NVRAM?

Yes, I reset those too. No difference.

Any light that anyone can shed on this would be excellent! This looks like some hardware problem that is NOT a hard disk or memory, but what is it then?

And finally here is the text of the Safe Mode Kernel Panic:

panic(cpu 2 caller 0xffffff8000bcae5): "Process 1 exec of /sbin/launchd failed, err no 2"@/SourceCache/xnu/xnu-2782.40.9/bsd/kern/kern_exec.c:4033

VM Swap Subsystem is ON

FireWire (OHCI) Lucent ID 5901 built-in now active, GUID c82a14fffe7bde94; max speed s800.

FWOHCI : enableCycleSync - enabled count going negative?!?

Debugger called: <panic>

Backtrace (CPU 2), Frame: Return Address

0xffffff8093c33df0 : 0xffffff800032ad21

0xffffff8093c33e70 : 0xffffff80007bcae5

0xffffff8093c33ef0 : 0xffffff8000796b02

0xffffff8093c33f10 : 0xffffff80007d9011

0xffffff8093c33f50 : 0xffffff8000327256

0xffffff8093c33f80 : 0xffffff800041756e

0xffffff8093c33fa0 : 0xffffff8000433c6f

USBMSC Identifier (non-unique): 00000000 0x5ac 0x8403 0x9833, 2

BSD process name corresponding to current threat: init

Boot args: -x

Mac OS version:

Not yet set

Kernel version:

Darwin Kernel Version 14.5.0: Wed Jul 29 02:26:53 PDT 2015; root:xnu-2782.40.9~1/RELEASE_X86_64

Kernel UUID: 58F06365-45C7-3CA7-B80D-173AFD1A03C4

__HIB text base: 0xffffff8000100000

System model name: iMac12,2 (Mac-942B59F58194171B)

System uptime in nanoseconds: 1408457515

Update (04/30/2018)

I did not have bootable drive with Yosemite handy, and finding a direct download for it proved a headache. But I did have Mountain Lion in my list of purchases in the App Store, so I tried that.

Everything worked perfectly in Mountain Lion.

So why not then simply have a go and upgrade direct from Mountain Lion to High Sierra?

This set off the longest, slowest, and most complex Mac OS upgrade installation I have ever seen - multiple different progress bars at different stages (even a wider, rounded end one that I have never seen), and even a loud beep noise at one stage that sounded the same as the one you get when RAM is faulty in your Mac.

But now, after an hour of waiting for it to complete, it all now works.

This is the guide I used to make a Mountain Lion bootable drive (it's a little different to later versions of Mac OS).

So try a downgrade to Mountain Lion, then upgrade to High Sierra - and it all looks good!

Answered! View the answer I have this problem too

Is this a good question?

Score 0


I would clean out the logs (external boot drive) and let is panic again. You should then see a better footprint on whats panicking. You may want to do this a few times to see if the condition alters each re-boot. Using another Mac system recover the logs after each attempt.

Have you opened the system yet? If not I think you'll need to and check the CPU. Is the seal still present or not? If not I would pull the CPU and make sure the socket & pads on the CPU are spotless and make sure its the correct CPU.


Super Dan, thank you!

Re. logs and external boot drive - I will do that and report back.

And yes, I have opened it. The seals on the CPU are still present. Also judging by the way everything was arranged, and where the tape on cables was placed when I opened it, I am pretty sure nothing has been done to the logicboard since it was purchased. I knew the previous owner had opened the machine to remove the hard disk to recover the data from it, but that's all as far as I could tell. Still worth opening up the processor?


Let's get the logs for now. save them in a PDF's so I can compare them.


I’ve got a MacBook Pro 2012.

I've been having unjustified panic kernel problems for about a week. I tried all the solutions. I have no problems with the RAM, my HD or with third-party software.

I believe the Apple activates a daemon to force people to update the OS. I need to stop this situation because I have to finish an important job.

Can’t live like this.


Hi John,

I have the exact same issue as you have. Tried internet recovery and tried installing El Capitan, High Sierra and Catalina. Always having panics!

Why do you suggest going to Mountain Lion?


Show 1 more comment

Add a comment

1 Answer

Chosen Solution

What systems are you trying to boot from. I have have similar issues on a machine but it runs perfectly using Yosemite. If you put that system on an external and give it a try. I am also working with Apple on this one as mine is system related.

Was this answer helpful?

Score 3


Thank you - will give that a go too! At the moment I have tried it only with El Capitan and High Sierra. I now need to just get hold of a download of Yosemite...


Mayer - there is something to this! After a lot of messing around trying to get hold of old versions of Mac OS, I have managed to make the machine boot with Mountain Lion! :-) Super!

Now the question is what the next steps are going to be... I will research further and report back!


Apple makes this hard as they don't explain you need to walk through all of the updates one by one, you really can't jump over any.

So if you have Lion (10.7) you first need Mountain Lion (10.8), then Mavericks (10.9), Yosemite (10.10), El Capitan (10.11), Sierra (10.12), High Sierra (10.13) and lastly Mojave (10.14). This is due to the firmware updates that Apple now has within the OS installers.

But even this is not fully correct! You need to stop at what Apple dictates as the highest your system can go! In this system thats High Sierra (10.12).

But Apple sometimes throws us a curve ball! High Sierra was an experiment! IT was the first release of a new file system which is very good on PCIe/AHCI or NVMe SSD's its not good on older SATA based drives! So I don't recommend going to it so that leaves you as Sierra which is by far the best OS for these older systems!


Add a comment

Add your answer

Jon Worth will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 11

Past 30 Days: 53

All Time: 2,574