The Google Pixel is Google's first flagship phone, released on October 20, 2016. The 5-inch AMOLED display device comes with 32 and 128 GB storage options and is available in three colors; Very Silver, Quite Black, and Really Blue.

39 Questions View all

Phone call is taking time to show controls and connecting

I am using Google Pixel mobile. When I try to make a call from default phone app it is showing screen with Contact name & number for 15 to 20 seconds (attached the screenshot for your reference) and then it showing other controls. After that only call functionality is working.

I tried with uninstalling phone app updates first and then updated the app again. Still issue is not fixed. Is there any workaround for this ?

Block Image

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

Hi,

Try starting the phone in safe mode and see if it performs normally when making calls.

If it does then a downloaded app is the cause of the problem.

The trick is to find out which one

First backup the phone as a safeguard.

Then with the phone in normal mode, you need to uninstall each downloaded app one by one and test the phone after each uninstall to see if it works correctly.

When it does then the last uninstalled app is the culprit.

Was this answer helpful?

Score 1

Comments:

Uninstalled all the newly installed apps but no luck.

by

Hi,

Can only suggest that you backup the phone using the phone's backup feature and perform a factory restore using the phone's factory restore feature.

Then test if the phone works OK.

If it does then restore the phone from the backup that you made earlier and see if it works OK after the restore.

If it does then a factory restore has resolved the problem

if it still doesn't work correctly after a factory restore then there is a problem with the phone. How long have you had the phone? Check the manufacturer's warranty on the phone for your location and if the warranty period is still valid then follow the directions of the warranty about making a claim for a manufacturer's warranty repair, replacement or refund

by

Recently I got a security update. After that update one of my existing apps is causing the issue. First i tried with uninstalling newly installed apps but no luck. After that i uninstalled older apps as well. Then issue got fixed.

No need of factory reset!! Thanks for your answer.

by

Hi,

Thanks for the feedback.

Hopefully it wasn't the last app left to be uninstalled that was the cause of your problem.

Cheers.

by

Add a comment

Add your answer

Gopal Gajarao will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 5

All Time: 65