Made by GM. It's the eighth generation of a land yacht!

19 Questions View all

Radio and fan do not work

The radio went first. No lights and no music. Shortly after that the fan does not blow any air out of the vents. The fan switch lights up but no lights on the radio

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

Blower

Very likely your blower control module. Under the hood. Try jumpering 12V from the battery to the blower itself (purple wire, make sure black is grounded). If the fan works, it's probably the module.

You'll have to pull the maxifuse relay center (two 10mm nuts) and rotate it out of the way. The module is the device sitting in the top of the evap housing below (you can see it without pulling the maxifuse stuff). Has two plugs on it.

They're 150 bucks new, but a dime a dozen at the wrecker in Pontiacs, Olds, Buick, some Caddy's, etc if they had ECC and not manual (knob) climate control. Don't get the resistor pack from what most of the cars out there have. It will not work.

3 OUTERMOST screws only. Or it'll fall apart on you. Here's photos: http://www.pontiacbonnevilleclub.com/for...

Go here and down for a picture of the fuse box: http://pontiacbonnevilleclub.com/forum/v...

Was this answer helpful?

Score 2
Add a comment
Most Helpful Answer

It is possible that whoever wired the radio in, that there is a inline fuse that has blown,check on that. Also not sure about your fan unless the radio wiring is connected to the fan power. Take a multimeter and check if you get power to the fan. The light on the switch might be a separate circuit and may not necessarily indicate that your fan gets power. It may be the fan motor. Also do not forget to check all your fuses to make sure they are in working order. Good Luck

Was this answer helpful?

Score 2
Add a comment

Add your answer

Tim Condon will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 6

All Time: 1,167