Skip to main content

Model A1013, A1052, A1085, or A1107 / 1440x900 screen resolution

121 Questions View all

PowerBook will not boot / replaced DC board / battery not charging

My 17" Powerbook will no longer completely turn on. I have replaced the DC in board.

With no battery connected the AC adapter light is green. When turning on computer, it sounds like the hard drive or a fan is coming on. The caps lock button light can be turned on or off.

I am using a 65W adapter that is known to work in a Titanium Powerbook.

I have tried resetting the PMU using shift-control-option-power. And tried resetting the PRAM by holding command-option-p-r while powering on, but not making any beeps.

I've also reseated the RAM.

It seems strange that the battery will not charge (when I press the button on the battery no lights light up). I bought a new battery within the last year and it was working fine.

Any ideas?

Answer this question I have this problem too

Is this a good question?

Score -1
Add a comment

1 Answer

Most Helpful Answer

Try starting up without the battery. That failing, try starting up from the original system installation disk by inserting the disk and holding down the "C" key - without the battery. My first guess is a bad hard drive and bad battery connector. Let us know of any lights or sounds you get during these tests. Next remove the hard drive and try starting from the optical drive. If you can get it up, download and run http://www.coconut-flavour.com/coconutba... with and without the battery.

Was this answer helpful?

Score 1

6 Comments:

I tried without a battery and no luck.

I tried to to turn on the system and insert the CD but the drive will not accept the CD.

I had the problem before I installed the DC-in board but it might be possible that I did not reconnect everything properly upon rebuild? I wouldn't think this to be the issue as the problem is the same as before.

The hard drive is also fairly new, within the last 2 years I believe.

Thank you so far for your advice!

by

I've seen these fail to try to start at all with a bad hard drive. So I would remove it to eliminate it from the problem. I think you have at least two things going wrong here. I would also try it using an external monitor and then in Target mode.

by

Tried Target disk mode with no luck (screen did not show firewire symbol and connected computer sees no drive). No luck on connecting to external screen either. I will remove the hard drive next.

by

Disconnected the hard drive. Still no screen and will not accept a CD into the SuperDrive. I tried with a battery and just with AC adapter...

by

Do you think this is probably a logic board issue?

by

Show 1 more comment

Add a comment

Add your answer

Nick B will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 878