Skip to main content

Model A1502 / 2.4, 2.6, or 2.8 GHz dual-core Intel processor / Released October 2013

417 Questions View all

MBP 2013 : major slowdown and random shutdown

Hello world !

I bought a mid 2013 MacBook Pro with Retina screen (a second-hand one) few months ago.

The problems I'm about to describe started for a long time ago (before these summer vacations).

The computer started to slowdown drastically with always the same problem in the activity monitor : the kernel_task eating more than 70% of the CPU (70% from the system without any other task opened).

The slowdown begins when I turn on the computer. The booting is really long.

The slowdown problem seems to not occur in recovery mode. That's why I can't understand where the problem comes from, software or hardware.

But there is another major problem : my computer shut down randomly, but more often when it comes out of sleep mode or when I plug/unplug the adapter.

When I'm trying to turn on the computer, I need to do a long press on the power button, if not the computer will crash. Rebooting is not affected.

I seriously fear a motherboard malfunction. This is my second MBP, the first was destroyed by water exposure.

What I tried :

Make clean installs of Maverick, Yosemite, El Capitan, Sierra and today High Sierra : no changes.

NVRAM/SMC resets : no changes

csrutil disabling : no changes

Deleting plist : no changes

Running the computer with battery unplugged : no changes

Increase fan speed with a fan controller app to prevent overheating : no changes

Free extensions boot : no changes, laggy with or without it

Unplugging all external devices : no changes

New Spotlight indexation : no changes

S.O.S of the disk : nothing wrong

Disable Flash Player : no changes

I'm running out of options. Here is the latest EtreCheck report I did (today).

EtreCheck version : 3.4.6 (460)

Rapport créé le 2017-10-13 14:37:00

Télécharger EtreCheck chez

Temps d’exécution : 13:52

La vitesse : Médiocre

Cliquez sur les liens [Rechercher] pour plus d’informations à partir des Communautés d’assistance Apple.

Cliquez sur les liens [Détails] pour plus d’informations sur cette ligne.

Problème : L‘ordinateur est trop lent

Informations matérielles : ⓘ

MacBook Pro (Retina, 13 pouces, fin 2013)

[Les caractéristiques techniques] - [Le guide de l’utilisateur] - [Garantie & service]

MacBook Pro - modèle : MacBookPro11,1

1 2,6 GHz Intel Core i5 (i5-4288U) CPU: 2-core

16 GB RAM Pas extensible


8 GB DDR3 1600 MHz ok


8 GB DDR3 1600 MHz ok

Handoff/Airdrop2: disponible

Réseau sans fil :  en0 : 802.11 a/b/g/n/ac

Batterie : Santé = Satisfaisant - Nombre de cycles = 399

Quota iCloud : 4.72 Go disponible

Informations vidéo : ⓘ

Intel Iris - VRAM : 1536 Mo

Color LCD 2560 x 1600

Informations des disques : ⓘ

APPLE SSD SD0128F disk0: (121,33 Go) (SSD - TRIM: Oui)

[Afficher le rapport SMART]

EFI (disk0s1 - MS-DOS FAT32) <non monté>  [EFI] : 210 Mo

(disk0s2) <non monté>  [Conteneur APFS]: 121.12 Go

Informations USB : ⓘ


Apple Inc. Apple Internal Keyboard / Trackpad

Apple Inc. BRCM20702 Hub

Apple Inc. Bluetooth USB Host Controller

Informations Thunderbolt : ⓘ

Apple Inc. thunderbolt_bus

Disques virtuels : ⓘ

MacIntosh HD (disk1s1 - APFS) /  [Startup] : 121.12 Go (107.01 Go libre)

Crypté : Oui (Déverrouillé)

Disque physique : disk0s2 121.12 Go (107.01 Go libre)

(disk1s2) <non monté>  [Preboot]: 121.12 Go

Disque physique : disk0s2 121.12 Go

(disk1s3) <non monté>  [Recovery]: 121.12 Go

Disque physique : disk0s2 121.12 Go

(disk1s4) /private/var/vm  [VM]: 121.12 Go

Disque physique : disk0s2 121.12 Go

Logiciels du système : ⓘ

macOS High Sierra  10.13 (17A405) - Temps écoulé depuis le démarrage : moins d’une heure

Gatekeeper : ⓘ

Mac App Store et développeurs identifiés

Agents de lancement systèmes : ⓘ

[Désengagé]    7 tâches d’Apple

[Engagé]    188 tâches d’Apple

[En marche]    93 tâches d’Apple

Daemons de lancement systèmes : ⓘ

[Désengagé]    38 tâches d’Apple

[Engagé]    187 tâches d’Apple

[En marche]    103 tâches d’Apple

Modules internets : ⓘ

QuickTime Plugin: 7.7.3 (installé 2017-10-03)

Panneaux de préférences tiers : ⓘ


Time Machine : ⓘ

Time Machine n’est pas configuré !

Utilisation du processeur par opération : ⓘ

10%   WindowServer

8%   mds


7%   sysmond

7%   mds_stores

Utilisation de la RAM par opération : ⓘ

937 Mo    kernel_task

245 Mo

156 Mo    mds_stores

107 Mo    Activity Monitor

105 Mo    AppleSpell

Utilisation du réseau par opération : ⓘ

Entrée    Sortie    Nom de l’opération

979 Ko    266 Ko

13 Ko     7 Ko      mDNSResponder

6 Ko      9 Ko      apsd

7 Ko      2 Ko      cloudd

4 Ko      1 Ko      netbiosd

Utilisation de l’énergie par opération : ⓘ


7.40 mds

6.88 WindowServer

6.18 sysmond

5.72 Safari

Informations de la mémoire virtuelle : ⓘ

12.46 Go  RAM disponible

10.74 Go  RAM libre

3.54 Go   RAM utilisée

1.73 Go   Fichiers en cache

0 o       Fichier d’échange utilisé

Événements du diagnostic (3 dernier jours si pas grave): ⓘ

2017-10-13 14:09:57    La cause du dernier arrêt : -79 - Échec de la batterie

EtreCheck report shows a battery failure, responsible of the last shutdown. Do you think these symptoms could be triggered by a battery malfunction ?

PS : I already asked on this website but none of the answers helped me. Here is a screenshot of the activity monitor today, this is weird because kernel_task isn't showed (but I know he's the responsible)

Block Image

Update (10/13/2017)

Ok so CPU overheating seems to occur in safe mode too. It's pretty random though.

Coconut doesn't show any problem with the battery.

I'm not really familiar with computers internals so here are pics of suspect areas.

Block Image

Block Image

PS: I posted it as an answer and not a comment because of the pictures, sorry

Update (10/14/2017)

Here are more detailed pictures of the heat sink area.

Block Image

Block Image

Answered! View the answer I have this problem too

Is this a good question?

Score 1


You mentioned this is a secondhand laptop, do you know if it has had any repairs done, or damage before you bought it? Most likely, something happened to it before you bought it, and it is causing these issues.


Nothing seem to happened to the computer.

It worked fine for months before this. I asked to the former owner.


this would be an excellent question that users like @danj or @mayer could definitely assist you with


That OK as an answer. Next download TGPro and see if you can find where the heat is being generated.

Please post a pict of the end of that heat sink and the surrounding area,


I just installed TGPro, after a 15 minutes warm up just after the computer boot (and another shutdown) there is no real heat. Without doing anything, the maximum temperature is located around the SSD (50°C approximately). All other measures doesn't exceed 30-40°C.

I'll post as an answer the pics of the end of the heat sink.


Add a comment

2 Answers

Chosen Solution

@carlin23 - I think I see your problem here! If you compare your 2nd pic of your first update with this one you'll see you lost a component!

Block Image

Note the missing resettable PolySwitch link (green SMT device). So your system got hit with a large surge which blew it up!

You'll need to check the rest of the circuit to see if something else got damaged or was the cause of this failure before you replace it.

I would recommend finding someone with the needed skills and tools to repair your logic board.

Was this answer helpful?

Score 0


I think this device is still here but seems damaged with something which looks like glue or something. No idea from where does it come lol.

I also noticed something today : my computer worked really well (no kernel_task spikes or shutdown after sleep mode).

I think the reason is that I didn't completely locked the bottom panel with the two little locks (sorry I don't know the real name of these).

Thanks, I'll check for a repair ASAP !


Add a comment
Most Helpful Answer

Boot up in Safe Mode by holding down the shift key on start up. Then check the CPU usage and tell me what you find.

Also download install and run Coconut Battery and post your finding.

Next take off the bottom cover and examine where the heat sink runs. Look for an oily type of residue on it or on the logic board especially at the tip where it is crimped.

Was this answer helpful?

Score 2
Add a comment

Add your answer

François Meresse will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 3

Past 30 Days: 16

All Time: 862