Second generation of iPhone. Model A1241 / 8 or 16 GB capacity / black or white plastic back. Repair is more straightforward than the first iPhone. requires screwdrivers, prying, and suction tools.

1492 Questions View all

Could not activate cellular data

I've got unlimited internet on my sim card as the phone is jail-broken, it worked for a few months then it stopped working and showed the message "could not activate cellular data". I have restored all settings a few times and it still says the same message. Please help!! I am going out of my mind!

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Which one, the A1241 or A1303?

by

What's your reception like? Have you tried removing and cleaning/ replacing SIM?

by

Its the A1241 and the reception is good must of the time really. I just tried to remove the SIM and clean it but it is still not working, I don't know what else to do but thanks for your suggestion.

by

I got the same notification quite a few times on my jailbroken iPhone 3G, but I was never able to use data in the first place, only Wi-Fi. Eventually, AT&T was able to find out I was using an iPhone and activated an iPhone data plan on my account.

by

Add a comment

1 Answer

Chosen Solution

Try calling AT&T and ask them if there's something going on with your data plan.

Was this answer helpful?

Score 2

Comments:

sensible suggestion... have you paid the bill? checked the settings etc?

by

Add a comment

Add your answer

Sophie will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 995