Released on September 19, 2014, this 5.5" screen iPhone is the larger version of the iPhone 6.

894 Questions View all

Whats possibly wrong with my Touch ID?

I cracked my screen and got it repaired at a local kiosk. Replaced my screen (albeit with a very crap, dim one with horizontal lines) and got Touch ID to work with this crap quality screen.

Not being happy with the quality of the screen, I bought this from Replacebase and installed it myself, moving over the home button.

https://www.replacebase.co.uk/for-apple-...

After installing this, Touch ID suddenly failed. Even putting back the crap screen - where it had worked before - failed! After getting refunds, I went to a professional service and got the screen replaced by quality parts but still no Touch ID. The add fingerprint section is greyed out and I keep getting the pop up saying unable to activate.

Interestingly I went to an AASP and they ran a diagnostics which immediately gave a error regarding Touch ID. What could have happened and why is it not working at all now when it once did ? Is there a way to fix this before forking out £300 with Apple :(

Thanks

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

@teetopp Thanks for the answer. Come to think of it, the socket for the home button cable was very loose when I was attempting to disconnect the home button from it. Could that have been a problem? This piece was actually glued down before. Im guessing the home button would not function properly (excluding Touch ID) if there was damage to the actual home button's cable? I will try find a metal shield.

by

There is an adhesive that holds the ribbon cable to the "Back Plate", as well as an adhesive that holds the "Socket" to the plastic frame of the phone to keep it from moving. You could use a bit of heat next time (Not too hot) to loosen the adhesive to allow it to lift without damaging the fragile flex.

Here is a link or 2 to the part I am mentioning... Just for reference purposes, these are just random picks to describe the part.

http://www.ebay.com/itm/like/15214757636...

https://www.fixez.com/iphone-6-plus-home...

You do not need the metal plate, as you have one if you can find a new flex caple to adhere to your back plate :)

by

Add a comment

2 Answers

Chosen Solution

A few things can go wrong with this, but most likely it is the flex cable connection that runs along the metal backplate. Or...the actual flex cable on the home button. lastly, the connector could have been damaged at the home button or on the motherboard...including the little components surrounding the logic board connection.

I would first try to inspect everything with magnification...but the fragile traces inside the flex will be almost impossible to see, so look at the connectors themselves and components around logic board.

Buy a new backplate or find a salvaged one.

If it is damage on logic board, then microsoldering would be required to repair and this is not a DIY job.

Worst case scenario, you have lost Touch ID but everything else should work great and be thankful you have other security options with PIN, etc...

Was this answer helpful?

Score 2

Comments:

This worked! I replaced the flex cable by getting a new backplate and the 'Add Fingerprint' option became available. Thanks for that. A quick heads up for others though, fingerprint will still fail after trying to register it. Simply perform a DFU reset and all will be back to normal

by

That's Great! Congrats!! Well done :)

by

Add a comment

hey there!

many things can cause this failure.

Most commonly is a small tear in the extension flex or home button flex.

however, there are other options such as;

-Software corruption

-ESD

-or Component failure.

unfortunately, third parties do not have access to touch ID compatible parts, and you will need to get the screen replaced with apple. however, (in canada at least) Apple will not operate on a device that doesnt have an already OEM screen on it.

Im sorry, but it is highly unlikely that this will be able to be solved.

as a last resort, trying torun a factory reset MAY help, but it is unlikely.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Dipesh will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 1

Past 30 Days: 28

All Time: 66