Late 2011 model, A1278 / 2.4 GHz i5 or 2.8 GHz i7 processor.

380 Questions View all

Having weird issues with the fan

After too much investigation, multiple resets, PRAM reset, CMD R, S, CMD S, even replaced the CPU thermal paste twice with high quality Arctic Silver 5, I've narrowed down the issue I'm having to something related to the fan.

A bit of history, this is my Daughter's computer. She is on the final year of her Psychology major, so imagine how terrified is she with her computer failing on her. We don't live in the US, so visiting a genius bar is out of the question.

The symptoms are like this:

The computer have been running issues free since over two years, but a few months ago she had some issues with the trackpad. Like it was stuck and didn't click. I thought about replacing it, but a few taps cleared it out, and continued to work normally.

Then a couple weeks ago, she had some issues with the volume control muting, or bringing the volume down without pressing any key. And couldn't get the volume up with the keys, only with the screen slider. It also self corrected a couple days later.

But last Thursday, she called me all stressed out, that her computer was not turning on. It reached the login screen, and shut down.

I checked it out, and though that it was the thermal paste, so having a bit of Arctic Silver from a recent PS4 repair, last Sunday I replaced the paste.

When booting, it behaved exactly the same. So I started to freak out. I posted the question on the Apple support forum, and lots of people told me that it was the SATA cable, and that the SSD could have been corrupted. I put the SSD on an external enclosure and backed up all her files in my computer, so thankfully the data is safe. She also has a recen TM backup. I erased the SSD, and was planning on installing macOS from scratch. But every time I tried to do it, it didn't even finished loading. I don't really remember hearing the fan spinning up.

Yesterday, out of desperation, I took her apart and replaced the thermal paste again, but when reassembling, I forgot to connect the trackpad ribbon cable, and the keyboard cable was also a bit loose. So, I turned her on, to try to reinstall the OS, but this time something happened. I could hear the fan roaring. I started the installation, but the USB image was corrupted, and it failed. So I turned the computer off to change the USB installer. This time I reconnected the keyboard and the trackpad. Turned it back on, and the fan was silent. And shut down. I started to think that it's something about the fan, or the trackpad, so I disconnected the trackpad, and tried again. Same behavior.

This morning, I thought about the keyboard issues she was having, so I disconnected the keyboard, and tried again. Guess what, the fan roared again, and I'm in the middle of the new installation.

So, up to this moment, the keyboard is shorting something that keeps the fan from running at full speed. As crazy as it sounds.

Thanks for reading this far...

Any ideas?

Update (09/05/2017)

Well, it was a long boot. It took almost 12 hours to boot and run the App. Remember that I disconnected the keyboard and its backlight, and the trackpad.

Block Image

All I can see is that says that the Hard Drive sensor is not working. Is that the one on the trackpad?

So, if I replace the trackpad, will it fix the issue?

Thanks!

Update (09/06/2017)

Well, I just took the trackpad apart, and brushed it off with an old toothbrush and rubbing alcohol, making sure to reach every crevice where I can find dust and grit on, and put it back in. Booted, and it behaved normally. I was able to run TG Pro now, and it shows all sensors working 100%.

Here is the screenshot:

Block Image

I know is not a definitive solution, but is a proof that the computer is not damaged, is only a sensor issue. So I'll order both the trackpad and the SATA cable, as you mention, also doing the tape thing to protect it from rubbing on the metal case.

Thanks a TON for your help, Dan. You saved us a lot of grief, and my Daughter will be so happy to learn that she'll be able to finish her thesis.

Have a great day

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

The HD drive its self has a sensor. Can we try a second drive? If the 2nd drive also fails then the drive cable has a short. the 2.5" drives have SMART services which the system monitors.

You also do need to plug in the trackpad/keyboard cable for TG Pro to see the sensor thats on the trackpad.

by

Well, I'd love to do that, but the thing is that it doesn't go past the login screen. I just connected the keyboard and keypad, and it shut down at the apple logo, and the progress bar was not even half way. I've been trying to make it boot since Saturday.

Just tried again, only disconnecting the trackpad, and is back at snail speed, and the fan roaring. So, I think is safe to say that definitively there is something wrong with the trackpad, and I should order one ASAP.

Do you agree?

by

Yes and you might as well get the HD SATA cable as well. I recommend getting the newer 2012 version MacBook Pro 13" Unibody (Mid 2012) Hard Drive Cable - Apple P/N 923-0104 as it's a better part than the older one. I would also recommend you place some tape down on the upper case where the cable rests against it as the rubbing on the surface is what kills the cable.

by

Add a comment
Black Friday
Broken doesn't stand a chance.

1 Answer

Chosen Solution

You've hit a few different issues... let me start with the easiest one here first:

The so called installer corruption, it's not! Apple applies a certificate window on its installers so they are only good for about 2 years. So if you are trying to install an older OS you can encounter this warning. To solve it you'll need to fake out the installer by altering the systems date to a date that's within that 2 year window. Go into Data & Time settings alter the setting to manual vs Apple time server, then manually set the date and restart.

Now before you go down that path let's see if we can solve the underlying hardware issue you have. I suspect your daughter spilled something on the trackpad (and maybe the keyboard) which why it was sticky. What was spilled seeped to the underside of the trackpad and damaged the palm rest thermal sensor located there. To prove this you'll need to get this app: TG Pro. It will allow you to see the thermal sensors and the fans status.

If I'm right you'll need to replace the trackpad. Follow this IFIXIT guide: MacBook Pro 13" Unibody Late 2011 Trackpad Replacement.

If it's something else paste a full screenshot of the main screen of TG Pro so we can see what it's telling us.

Was this answer helpful?

Score 2

Comments:

You may also need to do some cleaning of the keyboard if the key switches got wet or you'll need to replace the upper case assembly.

by

Ok, is a new installer. I just downloaded the latest Sierra form the App store. The thing is, I put it on an external SSD driver that was having issues earlier, instead of a new USB stick, which I eventually ended up doing, since the external drive was indeed corrupt.

The OS installation is going very slowly, I presume is because is reading the stick at USB 2.0 speeds, which is painfully slow. Once I finish, I'll run TG Pro, and post the results.

Thanks for the help.

by

Sadly, it's more than that. Happy to hear you're using a more current OS. But with the thermal sensor acting up I fear you've hit the Safe Mode condition were the systems clock speed is throttled back quite far which is why your install is creeping at such a slow speed.

Is your daughters work all backed up? If it is, you may as well kill the installer and use an external bootable drive for now to test the system with TG Pro and fix the hardware. I fear it's going to take a day or two to get the install to finish at the throttled speed.

by

Yes, I was able to copy all the files in my computer, she also have a recent TM backup. Although I formatted the drive, and is not bootable. A few days ago, I cloned my 2016 MBP with Sierra before installing the High Sierra beta, and I can try to boot with that drive, and see if I can install TG Pro. I'll keep you posted

by

A quick update: I disconnected the keyboard and the touchpad. Is the only way to make it boot, and stay on. Is extremely slow, and the fan is at full speed. I connected the Sierra clone I had, and it booted. Even though it was created with a 2016 MBP with touchbar, talk about hardware compatibility, gotta love Apple for that. Anyway, it has been booting for 5 hours now. I can see the desktop, the dock, and some login items are beginning to load. I should have started with Shift, to avoid loading the login items, but is too late now. I inserted the USB where I copied the install package for TG Pro, but it hasn't appeared yet. I think I'll leave it on overnight, and hope that is fully booted in the morning, so I can run the program and send the results.

by

Show 1 more comment

Add a comment

Add your answer

Martin Ocando will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 10

All Time: 100