The Apple iPhone 5s was announced on September 10, 2013. Repair of this device is similar to the previous models, and requires screwdrivers and prying tools. Available as GSM or CDMA / 16, 32, or 64 GB / Silver, Gold, and Space Gray.

3187 Questions View all

iPhone 5s stuck in loading loop after battery replacement

I bought a replacement battery from iFixit and replaced it with no problems. My phone booted up and worked absolutely fine. I left the battery to drain as instructed in order to calibrate it and then set it on to charge. However, I seem to now be stuck in a loading loop. If not plugged in to power, I get the plug into power screen. When I plug it into power, I see the Apple logo, then a blank screen, then it turns off and returns to the plug into power logo. Can anyone help me to get out of this loop? Thanks in advance

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Black Friday
Broken doesn't stand a chance.

1 Answer

Chosen Solution

It sounds to me like the battery is not charging; therefore the phone keeps shutting down. iFixit batteries are very good quality but it is still possible that you have a bad one and besides, that is the easiest thing to try at this point. You may want to contact iFixit Support.

You don't say why you changed the battery in the first place...did it suddenly die or was it degrading over time?

Battery issues are usually 1) battery, 2) Lightning port, or 3) logic board. You can easily isolate the problem but if i you have a logic board problem (charging circuit), then you will need to find a repair shop that does micro-soldering repairs.

Start with the battery though...

Was this answer helpful?

Score 1

Comments:

I changed the battery because mine was slowing losing all ability to hold its charge after nearly 4 years! The old battery did charge beforehand and everything worked perfectly minus the fact the battery only lasted about 4 hours. It does seem like the battery isn't charging, will contact support.

by

Add a comment

Add your answer

Liam Abrahams will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 4

All Time: 40