Skip to main content

Early 2011 model, A1278 / 2.3 GHz i5 or 2.7 GHz i7 processor.

842 Questions View all

Why is the RAM not recognized?

I just installed upgraded RAM in a family member's MacBook. At the same time, I installed a new SSD and was starting up with an install DVD from the optical drive. I received the 3 tones repeatedly.

Tried reseating the modules, checking to make sure that I had the correct modules, reinstalled the old modules and have the same 3 tone result. Weird! I tried the individual slots, one module at a time with the same result.

There was some controversy on the iFixit procedure about wether to disconnect or not disconnect the battery before working on the Macbook. I opted to disconnect the battery and that seems to work fine, so am thinking that is unrelated.

I also tried resetting the SMC and PRAM with the same results.

Any thoughts on this???



Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Most Helpful Answer

Reinstall the old RAM and see if it still does it. Tell us what type of RAM you are trying to upgrade with.


Let's see if it is a bad slot. Try just one stick of the old RAM, put it in the bottom slot and give it a try. Then try it in the top slot.

Sometimes little pieces of debris can get into the contacts so closely examine them and blow out with canned air.

Was this answer helpful?

Score 1


Thanks Mayer! Yes, the old RAM still gives the 3 tone error. I'm upgrading with 2 , 4GB DDR3 PC10600 1333MHz modules. it seems that this must be some type of power circuit reset that is needed, although resetting the SMC didn't seem to work.


Hi Mayer, An interesting development.... I reinstalled the old hard drive to see if that was somehow related. Low and behold, the RAM was recognized and just fine. I'm now initializing and installing the OS on the new HD using a universal drive adapter, and then will install it again in the MacBook. So far so good. I don't understand how the new, yet to be initialized drive had anything to do with memory recognition. I've done this so many times, install a new HD and RAM at the same time, and haven't had issues, that I can recall anyway.

Thanks for your help! I'll keep you posted. It's good to see that you're still in the Forum here. I used to check in with you many years ago about troubleshooting :)


I also have a customer with a 15" 2011 that's getting the 3 Beeps. I've done everything I can thing of to fix it, test it. replaced RAM, tested slots, Tech Tool Pro, Atomic. It will run fine for a couple of days, then start the beeping again. I'm about to conclude it's the logic board.


These mysteries are so stressful but it feels great when you get them figured out, if you have any hair left :). Maybe a hard drive issue? I would have never thought this until my experience just now. A bad SATA cable or connection? I can remember having some type of mysterious error years ago that a bad SATA cable was to blame. Maybe you helped me figure that out.?


I have replaced the hard drive and cable on mine. I'm thinking ESD damage to the logic board. This can cause intermittent problems. This machine has been in four times now. Please keep me updated as to if this solved the problem.


Add a comment

Add your answer

randy3833 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 14

All Time: 1,091