The Apple iPhone 5s was announced on September 10, 2013. Repair of this device is similar to the previous models, and requires screwdrivers and prying tools. Available as GSM or CDMA / 16, 32, or 64 GB / Silver, Gold, and Space Gray.

3186 Questions View all

no usb detection unable to charge able to boot with charged battery

I got a device from a friend. The device didn´t start at all. Hard Rest......

Then I plugged a charged battery in and it booted to springboard. But the phone does not detect any USB connection. Even in DFU mode, my iMac doesn´t detect the phone. There were 3 missing caps near the battery connector. I replaced these. I checked the voltage on any component that is a need for USB detection and charging but all fine. In my opinion, the error should be caused by U2 chipset, but the voltage supplying this chip is fine and at the right value. Do you have any other ideas what could cause this problem? (no water damage, but he replaced his battery with a very bad third party battery)

Thank you in advance.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Did you try a new charge port?

by

Yes, I changed battery charging. The error is on the logic board itself.

by

and charging port flex

by

I even installed the logic board in a working 5s housing but the same result.

by

And the battery drains quite fast.

by

Show 2 more comments

Add a comment
Black Friday
Broken doesn't stand a chance.

1 Answer

Chosen Solution

As @benjamen50 suggests, changing U2 at this point is the logical thing to do. Even through the supplied voltage is correct does not mean that the IC is not defective. Remember that U2 is above all a communications IC, not a charging IC. If anything is wrong on the communication protocol lines, the phone will not recognize the battery or accessory and nothing will happen, including no charge.

I'm also a little concerned about the missing caps. This could have been a simple prying error but it could be indicative of more damage, possibly caused by a really bad repair attempt. The poor quality battery could also have cause issues on the logic board. Do you know if your friend used original cables and chargers?

Was this answer helpful?

Score 2

Comments:

I Ireplaced the U2 but still no USB connection. So the last thing to check should be the qualcom baseband chipset.

by

Have you tried another charging port yet?

There was one rare occasion where I had to replace the charging port and the U2 Tristar Charging IC at the same time.

by

Yes, I placed the logic board in a working 5s and even tested a brand new charging port but the problem continues.

by

Add a comment

Add your answer

Marius Werdecker will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 51