The Apple iPhone 5s was announced on September 10, 2013. Repair of this device is similar to the previous models, and requires screwdrivers and prying tools. Available as GSM or CDMA / 16, 32, or 64 GB / Silver, Gold, and Space Gray.

3235 Questions View all

Displays apple logo then cuts off after battery replacement

Hi, hoping an iPhone repair guru can help me out. I have done several screens and a couple of batteries but never seen this before.

I recently replaced an iPhone 5S battery. Removed the pentalope screws. Opened up the screen. Disconnected the home button to find there was no metal cover (someone has been in here before). I removed the battery connector and the one next to it which I think is charging port. Metal cover for battery connectors were also missing here so I did prise a bit at the metal bit of the logic board next to them with no success before I realised this. I removed screen connection cover and disconnected screen. After a bit of prising I got the battery out and I did smell the battery acid so probably pierced it. I then put in the new battery connected it and put it back together. I tried powering on but only the battery symbol came up saying to charge. Tried charging for hours with no joy so assumed battery was faulty. I then ordered another battery and fitted it. Powered on the phone and it booted right up to lock screen whilst plugged into charger but started making a ticking noise. I noticed the charging symbol wasn't there so still not charging. I powered off immediately to ensure no further damage was done. I checked the battery connections and powered back on but now gets to the Apple logo for 1 second and screen goes black, no vibration occurs when I flick the silent switch. It then won't power on again for a while unless I press and hold power and home and the Apple logo will display for 3 seconds then goes black again. I tried the other battery in again but shows no power and doesn't attempt to boot. I have also tried without the charger port connected as well but doesn't help.

I'm not sure what the ticking noise was and I don't know if the logic board is damaged of how this could have happened. Maybe the battery blew something. Any help would be appreciated as I now have to give the owner of the phone £150 to cover his loss and I now have a dud phone.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

Chosen Solution

This is starting to look like a collage of problems/answers. You're gonna have t start ruling things out. At this point and time we could rule out battery, but until you get a known good one, not 100% ruled out. You'll want to test against a known good Lightning dock/charger port. If you can rule those things out. The next step would be a dfu restore to a backup. Whatever data not saved is lost. If that doesn't take, well then we're off to logic board repair. Sounds like you're just getting into level one repairs, so I wouldn't advise jumping into it. Without all the equipment and skills, that's a fast way to perma brick a phone

Here's a dfu guide

Plug your device into your computer with a USB cable.

Turn off the device.

Hold the Power button for 3 seconds.

Hold the Home and Power buttons for 10 seconds.

Release the Power button but keep holding the Home button.

Was this answer helpful?

Score 4

Comments:

Hi iMedic,

Thanks for your reply. I tried the DFU but no joy. I might have to order the charger port as it seems quite cheap. It did show 77% when it powered on for the second time before the ticking noise. If I was to disconnect the existing charging port and power on, would that confirm anything?

If not as you said logic board next but not sure if that's cost effective or not.

Thanks,

Jason

by

Well ordering one and having one that's known good are two different things. You'll have to test your parts, so you know the problem isn't coming from there. Board repair? To have someone else do it? Kinda cost effective. Depends on the repair. Could be reasonable, could be a junk board

by

If you pried against the board, look around the battery connector for missing tiny sized components. Possibly the gas gauge is gone.

But you will need a known good battery to confirm either way.

by

Add a comment

Add your answer

Jason will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 6

All Time: 53