The Apple iPhone 5s was announced on September 10, 2013. Repair of this device is similar to the previous models, and requires screwdrivers and prying tools. Available as GSM or CDMA / 16, 32, or 64 GB / Silver, Gold, and Space Gray.

3188 Questions View all

iPhone 5s home button bracket screws - how to unscrew

I can not get the iPhone 5s home button bracket off. I don't know if I'm using the wrong tool, 000 Phillips (purchased off ifixit), or it's just too tight.

The screws do not look like the traditional plus sign in a lot of the photos I've seen online.

Any ideas?

I'm also not sure how to upload photos on this so you all can see what I am dealing with.

Update (04/08/2017)

Could the screws be stripped?

Update (04/08/2017)

Here is a photo of what the screws look like.

Block Image

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Oh wow. Try a larger Phillips and a rubber band between the screw driver and the screw. If rubber band doesn't work a small piece of electrical tape has worked for me in the past.

by

Add a comment
Black Friday
Broken doesn't stand a chance.

2 Answers

Chosen Solution

I never use my 000 Kooku driver. It's real nice too. Shiny metallic purple. Rubber gaskets on the handle. Rotating head works much smoother. But it doesn't work. I use my 00 Best driver. Works every time. Does fail from time to time. Bought four of em in my day. Apparently they just straight up don't make a 00 driver over at Kooku

Block Image

Was this answer helpful?

Score 1
Add a comment

Hi,

I have done a lot of this particular repair. The 000 Phillips usually does the trick, however, in some instances where my customer has had their screen previously replaced by another repair shop sometimes I run into issues where that repair shop put different screws in. I don't know if this is due to lack of screw management or if it is that repair shops personal choice.

If it were the right screw you wouldn't have any trouble with it being too tight as the screws are too short to screw in too far to avoid damage to the front of the display.

Unfortunately, without knowing for sure I would guess that the issue is that incorrect screws are in the device. You might have to try several sized screw bits and hope for one of them to work.

Good luck.

Was this answer helpful?

Score 0
Add a comment

Add your answer

HelpMe will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 13

All Time: 65