Early 2011 model, A1278 / 2.3 GHz i5 or 2.7 GHz i7 processor.

577 Questions View all

MacBook Pro looses SSD after a while

I have bought a brand new ADATA SU800 SSD for my macbookpro (early 2011 running sierra).

I tried installing from USB but everytime after advancing for a while (even upto 80%) macbook looses SSD. All logs refer to be unable to write on the disk.

I use 'Disk Utility' first to remove partitions (works perfectly) but after loosing the disk, 'Disk Utility' doesn't see it. I also tried fdisk on the shell with the same result.

Here are some other facts:

1 - SSD is firmly secured.

2 - SSD works perfectly on my Windows and Linux desktop machine (I tried ADATA's test tool with quick test)

3 - SSD works on the mac when I boot from an external hard disk with macos installed but when I try to clone on it, it works but suddenly stops.

Anybody can help to work out this strange problem?

Thanks a lot

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Mine is working properly with the original HDD. It does not work with SSD due to 6gbs clock of SSD

by

Add a comment

1 Answer

Chosen Solution

Change the hard drive/IR cable and install a 2012 model.

MacBook Pro 13" Unibody (Mid 2012) Hard Drive Cable

Here's how: MacBook Pro 13" Unibody Early 2011 Hard Drive Cable Replacement

MacBook Pro 13" Unibody (Mid 2012) Hard Drive Cable Image

Was this answer helpful?

Score 4

Comments:

What is IR cable? BTW, I'm connecting it to the ribbon cable inside the macbook pro. I don't think I can replace that cable easily. In the meantime, the cable works fine with original 320GB HDD and also works with SSD for about 30 mins before loosing it

by

Googled it.

How on earth the cable might be the cause? How can I be sure that it is the cable before changing it?

by

We have encountered many systems which need the new cable - Trust us! Its needed! Also use the newer version of the cable that Mayer posted you to (2012 model)

by

Most get damaged as they come over the last step, right the edge. If you look at the guide, this is a less than a ten minute job to replace.

by

Add a comment

Add your answer

Hossein Mohammadi will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 5

Past 30 Days: 25

All Time: 301