The VTech InnoTab 2s is a kids education tablet that teaches them to read, write, and think logically and creatively.

4 Questions View all

Why is my device not turning on?

I'm pressing the power button on my tablet but it's not turning on.

Answer this question I have this problem too

Is this a good question?

Score 2
Add a comment

2 Answers

Most Helpful Answer

If your device is not plugged in using the VTech® recommended Power Adapter, then your batteries could need replacement. Check to see if your AA batteries aren't depleted. Try plugging in your device using the Power Adapter. One of these suggestions should help you with this issue.

If you plugged in your Power Adapter and you're still not able to turn on your tablet, then you might have an issue with that Power Adapter or with the power connecting port on the device. Consider replacing the power adapter or replacing the power connection port. If you replaced the batteries with working batteries and your device is still not powering up, then you might want to consider replacing the circuit board.

Was this answer helpful?

Score 3
Add a comment

Ensure that there are new batteries installed into the device. If using the power supply make sure that the power supply is plugged into a working wall socket. If it is plugged in properly you may need to replace the power supply socket, a guide can be found here for it.

Was this answer helpful?

Score 2
Add a comment

Add your answer

Esthevan Romeiro will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 38