Released October 24, 2011 / 2.2, 2.4, or 2.5 GHz Quad-core Intel Core i7 Processor

325 Questions View all

Main Hard Drive Bay - Sata Issue - Sata controller?

The machine used to be as such : Main Drive = Samsung 850 PRO 512GB / Caddy OWC = SanDisk Ultra II 960G. Boot on 850Pro and storage on Sandisk. (Both 6Gb/s if not mistaken)

Randomly on boot I have question mark folder. I swap the drives and can boot on the 850 Pro now in the caddie. Both hard drive mounted but when I try to copy on the Sandisk I am greeted with a "Error-50". I can now see the drive but not write on it. I check the drive (each) and they all works nicely over USB.

Fair enough, I order a new cable and install it. Same issue. I order "another" cable without the brackets this time and still have the same issue.

I tried the energy saver trick with no success (as it used to be a boot drive bay I had little hope on this one)

Am I to assume this is a SATA Controller failure ? Can it be a EFI problem ?

I am still rocking 10.11.6 (15G31)

Any help greatly appreciated.

Update (11/16/2016)

Block Image

Block Image

speed read from the two disk - 850 Pro in optical - and Sandisk in main bay

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

2 Answers

Chosen Solution

First there is a known issue within the logic board of some models so using a SATA III (6.0 Gb/s) drive in the optical carrier won't work reliably. Review this: OWC Data Doubler. It makes no difference who's you have, the information holds true with all of them. You have a MacBookPro8,2 system as you can see it has a Red note and if you go to the bottom you'll see the full explanation.

Basically, you need a FIXED SATA speed drive and it needs to be SATA II (3.0 Gb/s) to fit into the optical drive carrier. Auto speed sensing SSD's (or HD's) don't reliably work (ones that support SATA II (3.0 Gb/s) as well as SATA III (6.0 Gb/s) systems.

You'll need to get a larger SSD and put it into the HD bay and forget the optical drive dual drive setup. Or, find a FIXED SATA II (3.0 Gb/s) SSD which is almost impossible to find today. I would not put in a HD in the carrier as the optical drive bay does not have crash guard protection (only the HD bay has it) so if you bang the system while it's running it could damage the HD.

Was this answer helpful?

Score 1


Thank you for all the insights on this. Where I am confused, is that, at the moment the my caddy bay is hosting my 850 Pro and it's booting, working fine and I am having the speeds expected from a SATA III. I have also run apple hardware tests and no issues came up. Also the dual bay setup as been working fine for over a year now. I just do not want to retrograde before being sure there is no other way (it would dread me so bad). I have just looked at insulating the cable and will try this asap.


See if replacing the HD's SATA cable helps.

If you open up the system profiler page > About this Mac > System Report. Under SATA/SATA Express you can click on the different drives 'Intel Chip Set' header to see what the port is able to run at and what the device has negotiated at. Again remember the port will be listed as link speed 6 gigabit but the negotiated link speed is whats important here. The optical drive port will show 6 but is unable to really run that if you have the model which has the problem.


As I said here are both speed. I have now insulated the cable. Normal hard drive are reading but every SSD is just not bootable from main bay - but working fine over usb or optical bay. I'm just puzzled now. I have to assume the controller is bad or something is wrong with the motherboard. :(


I have replaced the cable twice now and even the original one that seemed to be the problem is reading normal HDD.


Then we're back to the optical drives port problem (logic board) which you can't overcome. Did you read the note in the OWC link and verify if your system is one of the effected versions?


Show 2 more comments

Add a comment

i have the same model and also having reliability issues after increasing hdd storage capacity in the optical caddy to 2.0TB... Strangely though, i ran the system for 2yrs with a 240Gb SSD with OS+ Apps in the HD slot, and a 750Gb 7200RPM Sata3 HDD in the optical drive caddy without any issues. After a lot of research, nobody seems to be able to pinpoint an exact source of the problem. Seems to be logic board based as some can handle sata 3 up to a certain drive size/power consumption, but mixed results seem to be dependent on drive size vs speed of data transfer vs power drain from drive vs shielding of drive and quality of connections between drive and board... aka a nightmare to pinpoint an exact culprit with so many variables at play... Im still trying different approaches to achieve a stable & fast solution without buying another drive as im really keen on the 2TB internal storage for dj gigs, but stability is also critical for this purpose. Currently additional shielding and insulated wadding to keep connections tight has helped a bit but if i really work it hard transferring multiple large files, the instability returns. Did you find a fix without a dedicated sata 2 drive?

Was this answer helpful?

Score 0
Add a comment

Add your answer

Vincent A will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 4

Past 30 Days: 28

All Time: 1,062