The Mac Pro First Generation is an Intel Xeon-based workstation computer manufactured by Apple Inc. The first generation model includes the machines from 2006 through 2008.

264 Questions View all

EFI and Firmware update from 4,1 to 5,1 for Sierra Upgrade Solved

It appears Apple is not supporting an upgrade to Sierra on my Early 2009 Mac Pro 2x2.93. It must be they feel it is not fast enough even though it benchmarks at 12612.

BTW a Apple iMac "Core i5" 2.8 21.5-Inch (Late 2015) benches at 11342

More planned obsolescence by Apple.

macOS Sierra hardware compatibility list (no longer supported):

  • Late 2009 and later
    • MacBook
    • iMac
  • 2010 and later
    • MacBook Air
    • MacBook Pro
    • Mac mini
    • Mac Pro

Anyway:

I have read that all I need to do is update the firmware from 4,1 to 5,1 and I will be fine.

http://forum.netkas.org/index.php/topic,...

Downloaded the update but I get Error 5570 when tying to run it.

A web search says I need to run Apples EFI Mac Pro firmware 1,5.

https://support.apple.com/kb/DL1321?loca...

But it will only install on the 2010.

I know we are going to have a lot of questions on Sierra when it hits next week and I would really like to be able to learn the system.@danj I hope you might be able to help.

UPDATE 9/15/16

I got by the 5570 error code by opening the MacProEFIUpdate dmg but not running it.

Then running the MacPro 2009-2010 Firmware tool ( ran OK without getting the error).

Said to shut down and restart holding down the power button until it started flashing.

I did this a couple of times. It looked like it was going to work but I did not get a firmware progress bar, it just booted normally. And I still have Boot ROM Version: MP41.0081.B07. The problem is the same as stated here:

http://forums.macrumors.com/threads/anot...

Mine is at the B07, so the EFI updater should work but still will not.

FURTHER UPDATE

Tried it three times and failed. Booted from a clean system on an external drive and success. Now have Boot ROM Version: MP51.007F.B03

I do not get the error message when trying to download the macOS Sierra Master Beta, it's just doesn't download.

UPDATE 9/20/16

Installed Sierra on external drive and booted from it on the MacPro. All appears to be running well, just one incompatible software and that was Symantec Endpoint Protection. Will play with it this way for a few days to see if there are any other issues but it's really starting to look like Apple just wanted to make the machine obsolete prematurely.

UPDATE 9/29/16

After testing for a few days using an external with Sierra and finding no problems, I went ahead and installed without issue on my MacPro. Using a Logitech QuickCam Vision Pro Webcam w/ Mic camera and microphone. The camera does not do well in low light and is not near the quality of an iSight. Siri runs fine with it and I can now send messages verbally to anyone in my address book.

I will be trying an install on a 64 bit early 2009 MacBook Pro this weekend.

update

2009 would not boot from external Sierra drive. Circle with bar.

UPDATE 10/5/17

This MacPro is now running 10.13 High Sierra with no problems.

Answer this question I have this problem too

Is this a good question?

Score 8

Comments:

@Mayer - Been playing with it a bit, nothing really surprising here (I don't have any older Mac Pro's any more). Siri is a lot of fun ;-}

I think iOS will be a bigger issue for most.

by

@mayer - Apple just released macOS Sierra for download! macOS Sierra Now Available as a Free Update

by

Can upgrade the firmware on mid 2009 MacBook Pro to trick into thinking it's Mid 2010 Because I looked at the specs there very similar

by

Add a comment
Deck the Halls
With tools and Fix Kits

5 Answers

Most Helpful Answer

For the 2009 Mac Pro Firmware update, you need to disable System Integrity Protection first. Here's a quick data dump--I'm about to do this myself.

As you may know, some Mac Pro models have been introduced that are identical or very nearly identical to the model that preceded them. Such is the case with the 2007 Mac Pro (MacPro2,1) and the 2010 Mac Pro (MacPro5,1). I decided to see if it was possible to come up with a way to update the firmware on the 2009 Mac Pro with the firmware from the 2010 Mac Pro. The hardware of these models is very close. The only thing that differs is the CPU socket mechanism on the dual CPU model, which uses Xeon CPUs with the IHS (Integrated Heat Spreader) removed, and the SMC firmware version. The CPU socket issue is transparent to the firmware, and the SMC firmware difference between 2009 and 2010 models is not an issue. As long as the SMC firmware version matches between the main board and the CPU board, everything works perfectly.

To explain how this was accomplished, let me first describe how the firmware update process works on a Mac. The firmware updater package, after checking that the Mac can use the update, places an EFI boot file named EFIUpdaterApp2.efi, which is very similar in structure to the standard boot file that starts a Mac on the system volume, in the /System/Library/Core Services/Firmware Updates folder, along with the actual firmware image. This boot file is then blessed in a special way, and the next time the Mac is booted from shutdown, with the power button held down for a few seconds, this special EFI program is run.

So how do we get the program to load the other firmware? It turns out that it is surprisingly easy. Inside the EfiUpdaterApp2.efi program are a list of firmware version strings from different releases of the 2010 Mac Pro, along with the CRC32 checksum of the firmware image file. If one of the firmware version strings is modified to what the 2009 Mac Pro model is, and the CRC32 checksum is changed to match the 2010 Mac Pro firmware image, and the firmware image filename is changed to the 2009 Mac Pro firmware image filename, then all is well.

I have tested this myself, on both 2009 and 2010 Mac Pro models. You can upgrade or downgrade at will. If you have a CPU in a 2010 Mac Pro that isn't supported in the 2009 Mac Pro, such as the Westmere 6-core Xeon, the system will not boot after the update until a compatible CPU is installed. I started off with just a few scripts and files in a folder to do this, but as a service to the community, I have written an installer program that does everything automatically. The program checks the Mac Pro model and will install the 2009 Mac Pro firmware or the 2010 Mac Pro firmware, whichever is appropriate. If you have a 2010 Mac Pro with a 6-core Xeon, the program will warn you, but still allow the firmware update. The download does not contain any firmware updater files or image files. The program creates a small RAM disk, downloads the needed files, copies all of the scripts to the RAM disk, and then runs the scripts. Everything is left on the RAM disk for you to look and and study, if needed.

I hope you enjoy this utility, and enjoy the benefits of extending the value of your Mac Pro.I have a fairly non-standard configuration, but it turned out that all I needed to do was disable SIP in OS X 10.11 to get it to work.

In El Capitan, Apple has enabled System Integrity Protection. You need to disable it in order to update the firmware. Here you go...

Download:

1. Download Mac Pro 2009-2010 Firmware tool

2. Download firmware for Mac Pro 5.1 (MacProEFIUpdate.dmg)

Disable System Integrity Protection:

3. Restart your 2009 Mac Pro holding Command + R (you will restart into Recovery Mode)

4. In Recovery mode, click on "Utilities" and select Terminal

5. In Terminal, type csrutil disable

6. Press Return

7. Restart Mac Pro

Run Updater:

8. Once restarted, Double click (mount) MacProEFIUpdate.dmg

9. Once it is mounted on desktop, Run Mac Pro 2009-2010 Firmware tool

10. Shut down Mac pro.

11. Once shut down, hold the Power Button until you hear a tone, and let go.

Your computer will now upgrade firmware.

Last steps..

Enable System Integrity Protection:

12. Restart your 2009 Mac Pro holding Command + R (you will restart into Recovery Mode)

13. In Recovery mode, click on "Utilities" and select Terminal

14. In Terminal, type csrutil enable

15. Press Return

16. Restart Mac Pro

Done!!

I had another look at the problem I was having. The fix is even simpler than described earlier.

Download the Mac Pro Firmware update 1.5 (MacProEFIUpdate.dmg) from Apple: http://support.apple.com/kb/DL1321

With the downloaded .dmg on the desktop, double click to reveal the package.

Now run the Mac Pro 2009-2010 Firmware Tool.

There is no need to rename or replace anything. The Firmware Tool grabs the package and does its magic with no 5570 error message.

Why we now need to manually download the firmware is another question.

Thank you so much...I did the firmware upgrade so many times without issues, then "error 5570"...I tried for 3 hours, from replacing the memory,

CPU, Video Card, dual processor to single processor, I should have just read your post.

I have a Sapphire HD 7950 3GB GDDR5 Mac Edition Graphics Card. I swapped that for the original card, and it made no difference.

I also have a OWC Mercury Accelsior PCIe SSD. I didn't remove that, but I did try upgrading the firmware from a 10.11 install on a drive on the built in SATA bus and that didn't work either.

In the end I was able to upgrade the firmware to 5,1 from the OWC Mercury Accelsior PCIe SSD, with the Sapphire card installed, simply by going into recovery mode and disabling SIP.

I hope this info helps someone.

Turning Off Rootless System Integrity Protection in Mac OS X

Again, the vast majority of Mac users should not disable rootless. Disabling rootless is aimed exclusively at advanced Mac users. Do so at your own risk, this is not specifically recommended.

1 Reboot the Mac and hold down Command + R keys simultaneously after you hear the startup chime, this will boot OS X into Recovery Mode

2 When the “OS X Utilities” screen appears, pull down the ‘Utilities’ menu at the top of the screen instead, and choose “Terminal”

3 Type the following command into the terminal then hit return:

4 csrutil disable; reboot


5 You’ll see a message saying that System Integrity Protection has been disabled and the Mac needs to restart for changes to take effect, and the Mac will then reboot itself automatically, just let it boot up as normal

You can also issue the command by itself without the automatic reboot like so:

csrutil disable

If you plan on doing something else in the Terminal or OS X Utilities screen you may want to leave off the auto-reboot command at the end, and yes, in case you were wondering, this is the same recovery mode used to reinstall OS X with Internet Recovery.

Once the Mac boots up again, System Integrity Protection will be disabled entirely in Mac OS X.

Checking the Status of Rootless / System Integrity Protection in Mac OS X

If you want to know the status of rootless before rebooting or without rebooting the Mac into recovery mode, just issue the following command into the Terminal:

csrutil status

You’ll either see one of two messages, enabled indi:

$ csrutil status

System Integrity Protection status: enabled.

or

$ csrutil status

System Integrity Protection status: disabled

If at any time you wish to change the status of rootless, another reboot into Recovery Mode is required.

How to Re-Enable Rootless System Integrity Protection in Mac OS X

Simply reboot the Mac again into Recovery Mode as directed above, but at the command line use the following syntax instead:

csrutil enable

Just as before, a reboot of the Mac is required for changes to take effect.

As previously stated, the vast majority of Mac users should leave rootless enabled and embrace System Integrity Protection

Actually I found the solution on Netkas.org. The site was down for a good portion of today and I wasn't abel to search their archives.

Apparently all you have to do is this:

Download the Mac Pro Firmware update 1.5 (MacProEFIUpdate.dmg) from Apple: http://support.apple.com/kb/DL1321

With the downloaded .dmg on the desktop, double click to mount the image.

Run the Mac Pro 2009-2010 Firmware Tool. It will automatically locate the package and proceed to the next phase of reboot and power switch hold until the little light above the power button begins to flash or you hear a long beep.

There is no need to rename or replace anything. The Firmware Tool grabs the package and proceeds with the process with no 5570 error message.

Hope this helps other Mac Pro 2009 users who are attempting this firmware update.

#10

After disassembly I could see that the previous unlidded CPUs had allowed the copper heatsinks to rest directly in contact with the standoffs. So I measured the thickness of the unlidded E5520 and lidded X5690 and found a 2.2mm height difference, which I accommodated with 2 washers plus foil shims to make up the exact height. Used thin "asterisk" pattern of NT-H1 on the CPUs and built up 3mm thermal pad on each heatsink. Clipped the fan connector tabs and seated them fully in their sockets before beginning to screw down the heatsinks. Tightened down each screw in the recommended pattern and got about 3.5 turns until "finger tight" and heat sink was just meeting the washers, and went no further. Confirmed visually that the NT-H1 had spread to all edges of the IHS on each CPU.

Installed one CPU at a time and got a boot chime + no diagnostics LEDs on the first try each CPU. After A CPU install, had successful boot but full fan after about 90 seconds as reported elsewhere (on Macrumors (http://forums.macrumors.com/showpost.php...)). Normal fan operation now after completing the B CPU install.

With the case open, I see idle CPU A/B temps at 36/29C and peak temps of 48/41C during a single Geekbench pass, with the Northbridge running at about 58C irrespective of load. No fans ramp up during the single-pass test.

Now to start running a 24-hr stress test and we'll see how it holds up!

Quote from: fabriciom on May 10, 2011, 01:35:40 PM

Can anyone confirm you can go back to your 2009 EFI?

Yep, I've had no problems going back to the 2009 EFI. It reverts to my original MP41.0081.B07 firmware, just something you need to be aware of in case you have one of those special refurb Mac Pros with the MP41.0081.B08 firmware.

It looks like you've covered almost all of the solutions. Did you rename the update to "EFI2010.dmg" and then mount it before running the firmware update tool? While using Mavericks of course, not El Capitan.

I know some say you don't have to rename it, but others do, so it's worth a try.

It is... Unless the Apple 5.1 firmware update is open on the desktop. A combination of issues led to all the trouble. I pulled the SSD hard drive running OS 10.11.3 from the PCI slot and booted 10.7.5 from a SATA hard drive. Disconnected from the 5770 GPU and connected to the old GT120. Loaded the 4.1-5.1 tool with Apple's 5.1 firmware update open on the desktop. That worked. At this point, I don't know why the GPU or PCI SSD would interfere but, all I know is that it only worked when they were out of the equation. I reset the pram and all is great. The 1333 ram shows as 1066 but, only because the new CPU isn't installed yet.

Was this answer helpful?

Score 4

Comments:

Once I got the firmware updated I have had no further issues.

by

Only got the updater to work after I turned off SIP. So if you try this and nothing happens, try that.

by

Jeffrey-

First, did you run Disk Utility or equivalent before installing Sierra? It could be that there are problems with your hard drive....

Do you have a backup you can boot from? Hoping you do!

Personally, I'd let it sit overnight, and if it's still not moving, I'd shut it down and reboot.

by

Thought I reposted but after a bit of a hang it finished and has been running fine since.

by

You can grab the firmware tool here: http://forum.netkas.org/index.php/topic,...

by

Show 2 more comments

Add a comment

Hey Rich:

You have two issues: First the physical firmware you have in your MacPro is version 4,1 and the only update Apple has is update 1.4 for that machine. As you know it requires the firmware 5,1 to work.

At this time Apple isn't showing any upgrade path for your machine. And given the list of what else Apple is dropping off in the way of software, it's unlikely Apple will issue a firmware patch for your machine.

You can see if you can request that Apple will make an exception, and issue a firmware update to allow it but everyone knows that will fall on deaf ears.

And like Dan said, there just may be too many issues in Sierra that a hack fix may not be able to address. Say hi to your awesome techs.

According to Apple forum the error 5570 is basically to tell you your 4,1 firmware 1.4 is already up to date: https://discussions.apple.com/thread/682...

Was this answer helpful?

Score 2

Comments:

@mactechplus Please read over the first link I gave. Also, makers of processor upgrades board for this machine swear that it can be done but I have to buy the boards for them to tell me. Do a search on eBay for "Mac Pro 2009 & upgrade".

This is strictly Apple not adding the machine to the plist. The 2009 MacBooks and iMacs will take it. Same thing happened on the 2008 server not going past 10.7.5. If you've noticed, Apple has abandoned the MacPro. We haven't had a new one since 2013. They have also abandoned the servers.

by

@mayer - While I'll agree the newer Mac Pro line is getting long in the tooth (it's not Apples fault, its Intel's). I don't think Apple is abandoning the Mac Pro line, just stymied by the lack of technical improvements in the workstation space (both in CPU & graphic chip technology).

Even today the best iMac (5K) still comes up short against the basic Intel Xeon E5 3.7 GHz 4 core (we use the 3.5 GHz 6 core). The newest Xeon E5-2699 v4 "Broadwell" which came out in March is a 22 core monster! And if you look back to the v3 and E5-2697 v2 they are 18 and 12 cores which are just not that useful for workstations as there clocks are slower and most apps are not able to take advantage of that many cores (threads)! I suspect the newer "Broadwell-EP" series is just not enough of an improvement for Apple to jump to.

What I want is a 14 or 10 nm 6, 8 & 12 CPU options but with much higher clock rates! Sadly, thats not on Intel's roadmap in the E5 line, I suspect the E3 line will get the bump. ;-{

The root issue is the CPU performance is still ahead on what the Apps we use today require for most of us. The bottleneck today for most is still storage and RAM limitations. Both are expected to see big changes in the next year or so. Maybe we'll see something then!

by

@danj I might still be able to get the beta and that may install on my machine, Do you know if it will. I see no reason for Sierra not to work on my Mac Pro since it will work on much, much lessor 2009 iMacs and Mac Books.

by

@mayer - Sorry, I have it working on an iMac. I don't dare update any of the Mac Pro's right now, I'll be lucky if I can in Dec.

See if you can create an external drive setup on a approved system and then see what happens when you use it to boot up under your Mac Pro.

by

@mayer been trying to install Sierra on a 2008 MacBook 4,1, still can't get it to work so far. Try the post on macrumors that's labeled Yosemite/el captain/Sierra on unsopporred Mac. That should all be the same tutorial if my guess if correct :)

by

Show 6 more comments

Add a comment

Hello,

i have the same problem with my MacPro4,1 RAM disk is created, but the update doesn't work

So, you just boot on an external hard drive a clean El Capitan system and run the Mac Pro 2009-2010 Firmware to perform the update ? Sound great ! Could you just tell me i'm right ?

Thank you.

Was this answer helpful?

Score 1

Comments:

I'm going to do my first 2009 MacBook Pro today so I'll be going over the procedure again. I have not done this since I did mine last Sept-Oct so let me get back to you this evening. If I don't shoot me a reminder.

by

I did my 2009 MP earlier this week, it went fine, running El Capitan, internal drive, no fresh one. Just make sure you turned off System Integrity Protection.

by

Add a comment

I can't get past the 5570 error on my 2009 early Mac Pro. I did the disable SIP and still no luck.

Was this answer helpful?

Score 0
Add a comment

I actually bypassed all of this by installing High Sierra on a 2012 mac pro and moving the hard drive to the Early 2009 Mac Pro 2 x 2.26 Ghz Quad Core... Boom. Running like a champ.

Was this answer helpful?

Score 0
Add a comment

Add your answer

mayer will be eternally grateful.
View Statistics:

Past 24 Hours: 181

Past 7 Days: 1,302

Past 30 Days: 6,045

All Time: 48,393