Released June 2012, Model A1278. Intel processor with Turbo Boost, Up to 512 MB DDR5 Video RAM

817 Questions View all

Issues with bottom RAM-slot MBP 2012

Hi guys,

I bought a used MPB 13'' Mid 2012 this week.

I got the system with 1 4GB RAM stick installed (in the top-slot) and the other slot being empty.

I bought myself 2x 8GB of RAM (Corsair Vengeance 1600Mhz DDR-3)

After putting in both sticks the macbook didn't start. No beeps, black screen, just 3 flashing/blinking lights at the LED indicator, with a 1 second pause in between the 3 flashes.

Put the old RAM back in the bottom slot, same problem.

Put the 8GB RAM back in the top slot, system boots normally with 8GB of RAM.

Pretty much tried everything after that, SMC reset, PRAM reset, loosening screws of RAM-bracket.

After that I tried to put 1 RAM stick back in the bottom slot, and tried to boot.

This time it booted, with black stripes flashing in the screen and the boot taking a very long time while the load bar was not progressing (hope this makes sense to read).

So I turned the system off, put the 8GB stick in the top slot and now working fine with 1 8GB slot.

Really would like the bottom slot to work as well, feels like i am out of options.

(Not going to replace the logic board for this problem)

Can anyone help, or has anyone had the same problems?

Thanks in advance!

Answered! View the answer I have this problem too

Is this a good question?

Score 2

Comments:

Hello,

I have the same problem. It's some kind of bad contact problem with the bottom RAM-slot and I don't know how to fix it.

@nawo13 did you find a solution on your problem?

I have a mid 2012 MacBook Pro.

Best,

Karim

by

Had the same problem with a 2012 13" MacBook Pro. Bottom slot has a bad connection to the logic board. With both RAM slots, in use the symptoms are as follows: displays stripes on LCD, freezing, reboots often, 3 beeps, etc. The computer will work fine if only the top memory slot is used. The only other solution is a logic board replacement.

by

Add a comment
New Battery = Faster iPhone
Fix Kits starting at $16.99

3 Answers

Chosen Solution

Sounds like you have either the wrong RAM module (spec) or the systems firmware is not up to date (I would be surprised if it's not already at the correct level).

With the 4 GB module in place with the system working lets first try checking the firmware. Follow this Apple T/N: About EFI and SMC firmware updates for Intel-based Mac computers. Make sure its at the listed level or newer.

If the firmware is OK, give us the part number of the Corsair you ordered and take a good image of the labels on one of the modules as well as the memory chips so we can read them and post them here as an answer.

Was this answer helpful?

Score 1

Comments:

Thanks for the reply.

Firmware is up to date (as expected)

RAM-module is Corsair Vengeance 16GB (2x8GB) 1600MHz DDR3

System (MBP Mid 2012) needs 1600MHz DDR3 RAM.

I think the problem is not the module, also tested it with the old RAM (that worked fine in the top slot) and tested it with Crucial Apple RAM 4GB (that worked fine in top slot and failed in bottom slot)

by

Then the RAM slot is bad. Jump down to Mayers solution as thats your only hope. Otherwise you'll need a new logic board.

by

before you change the logic board you can try some distance holders between ram bracket holder and top case ... the ram slot can be good, but the ram bracket holder looses contact to the mainboard. I had exactly the same issue.

by

Add a comment
Most Helpful Answer

Sounds like the original owner had the same issue. After you do what Dan says, if it is still doing it.

Try this: We've had reports that loosening the RAM bracket holder screws a quarter turn each has worked.

Was this answer helpful?

Score 2
Add a comment

Mayer 's tip is really good. At this model the RAM bracket holder often looses contact with the bottom side on the logic board (side you can not inspect without dismounting the mainboard). This leads to freezes, reboots, stripes and display errors.

ReSoldering the bottom side of the RAM bracket holder is quite a challenge and often you will get an offer to replace the whole mainboard (>400 USD !!!).

Option 1: you can use only one slot (the top one usually).

Option 2:

If you want to use both slots (instead of only one - either top or bottom) , you can try to put some distance holder between RAM bracket holder and top case. I solved once a time this problem with a short stripe of an old credit card. Put it between the RAM bracket holder and top case. This will "press" the RAM bracket holder to the mainboard or in other words, if you shake your Mac book pro or just type on the keyboard, the RAM bracket holder will not loose contact and the problem is fixed (yes with a workaround (0 USD :-) )

give it a try :-)

here a picture of the first tests. With this place holders no freeze, no reboot, ... :

Block Image

as said: it is a quick fix and take care to find the right distance - do no damage your logic board.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Nawo13 will be eternally grateful.
View Statistics:

Past 24 Hours: 7

Past 7 Days: 56

Past 30 Days: 346

All Time: 1,785