Sony ICFC1T alarm clock/radio is manufactured so that in the event of a power outage, you have the peace of mind that your device will continue working so you never miss an event.

14 Questions View all

Buttons not reacting even after change of the battery

The display was there but the buttons were not working. I have unplugged, changed the battery but still nothing. It shows 1. 1. then 2103, then 0:00 and remains blinking. The buttons do not react.

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

Did you manage to work this out its happening to me??

by

Had one with this problem just 15min after unpack.

Replaced, and the new one has same problems randomly once 1 or 2 months but removing battery and AC normally solves the problem.

by

a complete scandal to sony leaving a defective product to be sold and its authorizeds say that they can not do anything, that they laminate. i thinking quality sony be placed in the trash.

by

It worked ok during 6/7 months and all of a sudden the projector didn't work nor any button. After replacing the backup battery the unit keeps having the 0:00 time flashing for ever. I have tried multiple buttons sequence but didn't find the right combination yet. If a genius could help, I nearly convince that this is a software problem not a hardware fault. ANY IDEA ???

by

Add a comment

6 Answers

Most Helpful Answer

Take off the 5 screws on the bottom and carefully slide off the back assembly.

Take a voltage probe with the clock plugged in and check the power supply. By following the power wires into the PCB. The power solder joints should be above 5v even with a phone plugged into the usb charger.

Next i noticed that there was some kind of transient voltage across the back buttons of a few 100mV. This is incorrect. I tried to measure the current of one button to see if i could put the computer under an artificial button press. Next i noticed a different button came to 3.333V which is correct . I pressed it and it registered on the screen. Slowly but surely after I pressed the button with 3.333V others returned back to their proper voltage. Now all my buttons work.

This indicates ,to me: extreme static/noisy electricity, bad voltage regulators, or a weak capacitor somewhere.

Was this answer helpful?

Score 3
Add a comment

had the same... we returned to the shop and the shop owner gave us a new one... with the same problem again. so the shop owner opened all the boxes of the brand new delivery he just had received... showing that half of the clocks showed the same behaviour. obviously there is a failure in the transformator set, that only a part of the clocks works, a good share of the products do not get sufficient voltage... seems to be a problems of low workmanship quality ... now the product works fine

Was this answer helpful?

Score 1
Add a comment

Thanks aaron_delzeit for your indications. I repeated exactly what you described and bingo, when checking the back buttons voltage they came to 3 VDC and everything is working fine since then. No idea why just checking the rear buttons voltage they became operative again.

I had the radio-clock inoperative for 4 months trying to find a fix and this is the only one that worked.

Was this answer helpful?

Score 1

Comments:

The fix worked only for 1 week. Definetively the original cause of the problem is not solved.

by

Add a comment

Thanks aaron_delzeit and Ricardo P. for posting the fix. I tried it and it worked also. It is strange that I have to keep tapping the voltmeter probe to the button that has no voltage and all of a sudden, it beep. Then everything started working. My buttons only showed 3.25 VDC instead of 3.33 VDC. Well, as long as it is working, I don't care.

Thanks again!

Was this answer helpful?

Score 1
Add a comment

Has anyone ever been able to find the fault on these units? I have a dvb version very similar with must of buttons not working. Opened up cleaned and checked for any visual problem but looked ok. Put back together still same problem. Any genius out there? Thnx

Was this answer helpful?

Score 0
Add a comment

Someone on the Sony forum found the solution:

1- Remove the battery and unplug from the power source

2- leave the radio without battery and power for a minute or two

3- while pressing the ALARM RESET button conect to the power souce but do not install the battery

4- keep pressing the ALARM RESET button for another minute after pluging to the power outlet

5- Release the button, wait 5 seconds then set the radio according to your preference

6- after you are done setting the radio, re-install the battery

7- (Optional) if step # 3 doesnt work, press ALARM RESET and SLEEP buttons at the same time (you will see all the LED's turning on in the screen, and wont turn off until you remove the power source), unplug the radio, then proced to step #3

you should be good to go if you follow these steps.

Here's the link to it:

https://community.sony.com/t5/Other-Prod...

Was this answer helpful?

Score 0

Comments:

YaY, got it to work

by

Add a comment

Add your answer

mjesusmmartinez will be eternally grateful.
View Statistics:

Past 24 Hours: 18

Past 7 Days: 84

Past 30 Days: 341

All Time: 4,497