Skip to main content

Model A1419 / Late 2012 / 2.9 & 3.2 GHz Core i5 or 3.4 GHz Core i7 Processor, ID iMac13,2

319 Questions View all

SSD upgrade and kernel_task


iMac 27 late 2012 the ssd was upgraded but ths system doesnt see it. And the kernel_task use 500% of CPU. I think the problem is SSD. Where I can buy an SSD for it?

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Most Helpful Answer

Was this added as a primary or secondary drive? Did you install it directly or format it externally? If booting from your original drive use Disk Utilities and format the drive GUID before trying to use.


The 4sns/1/4000000 TH00-900 is a hard drive temperature sensor. Looks like the original hard drive has been changed without addressing the possible Apple priority firmware issue. lease tell us what the main hard drive is, make and model number and if it has an Apple logo on it. Your fan is probably running at high speed too. I'd like you to check your exact machine by entering the serial number here and let me know:

Next you need to get a cheap external enclosure or a universal adapter to address the SSD externally. Please tell us exactly what it is.

Was this answer helpful?

Score 3


iMac "Core i5" 3.2 27-Inch (Late 2012), I have removed the SSD becaouse it doesn't work. The HDD I think isn't genuine because there is no Apple logo and it is 3TB WD. And also I have changed the display.


Check again for an Apple logo, it might be stock. If it does not have one you will need to get a In-line sensor from OWC:

Standard Hard Drive: 1 TB (7200 RPM) Int. HD Interface: Serial ATA (6 Gb/s)

Details: This model also could be custom configured with a 3 TB hard drive for an extra US$150, a 1 TB or 3 TB "fusion drive" -- which combines a traditional hard drive with 128 GB of flash RAM -- for an extra US$250 or US$400, respectively, or a 768 GB SSD for an extra US$1300.


Hi. I have bought OWC cable as you adviced but the cpu overload doesnt disappear . Now I'm getting hard test error 4sns 1 c0000008 tl0p 124. What can I check? Any ideas?


Any ideas Mayer ?


Add a comment

Has anybody solved this mysterie ??

I have the same behaviour:

4sns 1 c0000008 tl0p 124

And a kernel tast taking 300% CPU load

Was this answer helpful?

Score 0


Hi. Yes The problem is solved. It was LCD sensor. There is a little wire with sensor behind the screen I had forgot to connect it :)


Thanks !!

I will check this !


Very strange.

The old panel does not have a connector to place a temp sensor.

The new panel does have the connector.

So i need to get hold of, or make a temp sensor to check if this solves the problem...


Add a comment

Add your answer

Vardan Hovsepyan will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 7

All Time: 1,245