Skip to main content

The Kindle Fire, Fire, or Amazon Fire is an Android-based media tablet by Amazon with a multi-touch color display. Repair requires only screwdrivers and prying tools.

797 Questions View all

I get a authentification problem

I connect to wifi but then it tries to reconnect almost immediately and I receive a authentication problem and it won't connect. Help!

Answered! View the answer I have this problem too

Is this a good question?

Score 3
1 Comment

I have the best solution. Don't buy Amazon fire/kindle fire ever again. This was my wisest solution after purchasing this trash a few months ago.

They are sub-par in every meaning of the phrase. I have an old Roku player 3 and even older western digital media player that doesn't have this authentication issue, yet the best solution is to restart your router. Why isn't this happening ot other devices? Because they are not useless brands. A brand new Amazon Fire tablet has more errors than there are words in a George R. R. Martin Novel. Not to mention one of the worst AI's in human history, Alexa, who is basically borderlining the invasive stupidity of Cortana from Microsoft. Do yourself a favor, and educate Amazon at the same time, and don't purchase garbage allowing lesser brands to flood the markets.


Add a comment

4 Answers

Chosen Solution


Are you entering the correct password for the WiFi network that you are trying to connect to?

Is it trying to connect to the same WiFi network every time?

Try the 'forget this network' option on the one that you wish to connect to, restart your Kindle, go to connect to Wifi network and select the network you want. You will need to know the password.

Update (03/07/2016)

Hi BettyEllen,

Couple of things to try.

1. Can you connect to the Wifi network using another device, e.g. a mobile phone? This will prove that the password being used is correct.

If it connects automatically without the need of a password (because it remembers it from being used before) 'forget' the network and then try to connect to it again having to use the password.

If it connects after entering the password then at least it proves the password is correct.

If you can't connect perhaps the password may be case sensitive or you are maybe using the wrong one. If you are trying to connect to your wireless router, try switching off the router, wait for a minute then switch it back on again. Allow it to initialize and then try to connect to it.

2. Try a 'reset' on your Kindle. Press and hold the Power button for 20-30 seconds, release and let the Kindle start. Try to connect to the WiFi network.

Was this answer helpful?

Score 2


I tried this several times and still have the same problem. Any other suggestions?

Thank you so much for the help


i have tried this also and still not connecting, even though other kindle in household connects with no problem.


blocking your kids access can sometimes do a reset and block all new devices. If this happens and you didnt activate a home router admin login, reset your router, clear your cache from problematic devices using mobile networks plus restart your device. netgear: allow all new devices buton linksys: use admin right box to create a new password if youre locked out. Wifi password is different from router admin password. wifi allows guests who knows the password on back of router, router admin controls users or intruders.


won't even bring up the password page


Why can’t we get an answer? The kindle has an authentication problem. Someone should know how to fix it!!!turn it off then on, hold this down, do this and that&&& It Don’t Work!!


Show 6 more comments

Add a comment

I haven't been able to use mine for like 2 years wouldn't connect when I got it but I had two so I said fudge it and used the extra one. Now my toddler broke the screen. So I went to other kindle went to connected devices and hit network setting reset and now it works 😑.

Was this answer helpful?

Score 0

1 Comment:

can you solve this by connecting the kindle by cable directly to the router ?


Add a comment

Hello All,

To fix this issue please ensure your router's WPA settings are not above WPA2.

WPA stands for wifi protected access which helps to protect WIFI passwords from being cracked. Login to your router go to advanced settings then wireless then security. Here you will see a drop down for security. if its set to WPA-3 please change it to WPA2-PSK (Do not worry this is still a secure protocol). Apply the changes to your router.

Once the change is completed you will need to reauthenticate to the network using the password.

I believe kindles cannot support anything higher then WPA2

Please let me know if this works for you.

Was this answer helpful?

Score 0
Add a comment

ixed it!!! OMG! Okay, googling lead me to an amazon page that mentioned changing my clock to the correct time zone. Well I haven’t turned this thing on in 2.5 years, it was still showing a previous time zone I lived in, and my password to my Amazon account had changed. Nothing I clicked on would let me change my password. After 3 hours I decided to try changing the clock. Well, for some STUPID reason that prompted an Amazon auth screen to pop up and let me sign in to my account with my new password. Dang thing works now. It’s downloading software updates as I type this. Good luck!

Was this answer helpful?

Score 0
Add a comment

Add your answer

BettyEllen will be eternally grateful.
View Statistics:

Past 24 Hours: 16

Past 7 Days: 177

Past 30 Days: 827

All Time: 39,616