mac pro 17" unibody 2010 not booting

Hello,

After a two weeks hiatus without using it, my 2010 mac pro 17" unibody does not boot up at all.

The magsafe button is orange (but not blinking), and when clicking on the button to see how much battery is left there is no light at all.

I tried SMC reset, tried with a different battery (I already replaced the battery 2 or 3 years ago when I added some ram), tried with another 85w magsafe, and the problem remains... It might be worth noticing that the magsafe button remains orange even when the battery is unplugged. Weirdest thing is that I didn't do any update, didn't have any accident with it either....

Please let it not be a faulty logicboard !

It is the first issue I encounter with it, I'm doing a lot of video editing with it and I neved had any hardware issues with it.

17" unibody

i7 processor

8 go ram

original SSD disk 128go

Thanks a lot for your kind help on this.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

A 17" needs some battery boost power to get it cranked up. Leave the Mag-Safe adapter pulled in overnight to see if it will take a charge. You'll need at least a 20% charge before trying to boot. Test #2 & #4 pins with a multimeter to see if they are putting power out. An 85 watt adapter is correct for your machine.

Was this answer helpful?

Score 1

Comments:

Thanks a lot for this. I forgot to mention that I already did try to leave the magsafe on overnight. What was weird was that the color on the magsafe is still orange and it usually takes just 2-3 hours to charge it to the max.

My guts tell me there might be a connection problem between the computer plug accepting the magsafe and something inside as the magsafe does look like it is charging but it does not. It does not look like anything is unplugged though....

Is it possible to remove or unplug the battery and be able to turn on the computer anyways ? I've tried that without putting the back aluminium protection and the screws and it wasnt working....

Thanks again for the help, much appreciated

by

Again, check the output of the mag-safe adapter. Make sure there is nothing in the female receptacle blocking contact. Use a wooden toothpick to test if the mag-safe pins are extending fully.

by

I'll try it asap and will let you know.

thanks a lot for your swift reply

by

Add a comment

Add your answer

arno2005 will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 107