Optical Bay SATA Hard Drive Enclosure can't be recognized?

I brought 9.5 mm SATA Optical Bay SATA Hard Drive Enclosure and equiped SSD (crucial Real SSD C300). Then I attached the enclosure unit in place of Optical drive, but MacBook can't recognize this SSD drive. I was pushing "Option" key in booting, no drive icon appeared.

Although I equiped SATA HDD (Segate 320GB HDD) to enclosure unit and attached it, MacBook can recoqnize this HDD.

I tried two SSDs, but neither can't be recognized by MacBook. I also tried to attach these SSD to 2.5 HDD connector (next to battery), then MacBook recognized this SSD.

What should I do ?

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

3 Answers

Most Helpful Answer

You need to format the drives for use

to do this, boot into your master that works

go to utilities in applacations

find disk utility

find the drive that needs formatting(one that dosent work)

find erase in disk utility

format it to MACOS extended(journaled)

Was this answer helpful?

Score 2


+ Good answer explaining what to do, and the steps required to do it.

by Taylor Arnicar

In "disk utility", the drive which doesn't work isn't appear in the disk list when this drive is connected to the connector which was used by optical bay. But I connect this drive to 2.5 HDD connector (next to battery), this drive appears in the disk list of "disk utility".

by Hiroki Kashiwazaki

then take it out and format it in that or the connector and HDD may be loose

by Nick

If the disk utility finds the drive in the enclosure use your install disk to format it and then try again in the optical bay.

by rj713

Add a comment

I have the same problem - neither the SSD or a 7200 RPM 3.0Gbps HDD will work on the optical SATA port, but work fine on the regular slot.

Oddly Apple aren't that interested in helping :-)

Was this answer helpful?

Score 0


The reason is apple leaves this stuff to you unless they do it

by Nick

Contact ifixt sales directly

by machead3

Add a comment

Similar problem here. I can hear the hard disk spinning, but the enclosure doesn't even show up in System Profiler. Any solutions?

Was this answer helpful?

Score 0


contact ifxit directly

by machead3

Add a comment

Add your answer

Hiroki Kashiwazaki will be eternally grateful.

View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 9

All Time: 3,233