Released on October 23, 2012. Core i5 or Core i7 Processor. Apple Fusion Drive.

153 Questions View all

Read Fails on Dual Samsung 850 Evo SSDs

I finally made the jump to upgrade my 2012 Mac Mini to dual Samsung 500gb 850 Evo SSDs and between the ifixit guide and the kit – everything went swimmingly. The issue arose once I tried to get OS X back onto the drives. I wanted to do a clean install from a USB drive or Internet Recovery and both kept failing. It would install, but I'd get the "no" error on boot (the circle with a slash through it).

I finally thought to install OS X on the other drive and it went in without a hitch. Looking in Disk Utility, the problem drive is the "upper" one (the one with the ifixit cable).

I ran a speed test and was getting the expected 500MB/s speeds on the "lower" drive, and the write test for the "upper" drive was 500MB/s, but the read test completely failed. Perplexed, I switched it out for a traditional HDD in that spot and everything was gravy. I even put that SSD in an external enclosure and everything was working fine on multiple machines.

Does anyone have any thoughts on why that may be happening? Did I miss something obvious during my research or install? Am I doomed to suffer?

Thanks!

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

Can you explain how you have the drives setup. Remember you can't use a Fusion setup.

by

Hi Dan! The drives were just independently installed in both bays. They're not RAID, fusion, or anything special. Just a couple o' drives. I was planning on using one to boot from and one to use for whatever (backups, media ,etc).

by

Add a comment

1 Answer

Chosen Solution

First make sure you have the latest firmware for both the system and the SSD's

Apple: About EFI and SMC firmware updates for Intel-based Mac computers

Samsung: Samsung 840 EVO Firmware - You'll need s CD burner/drive to create & install the update.

You may also need to replace the IFIXIT cable some people have had problems using it in a dual SSD config and lastly you do need the current release of Yosemite.

Don't forget to go into system prefs to select the start up drive.

Was this answer helpful?

Score 2

Comments:

Thanks for the info, Dan! I checked and the Mini is up to date with both EFI and SMC firmware and there doesn't seem to be any firmware updates for the 850 Evos yet.

Your post made me think to do a smc reset though. Not sure if it'll help, but worth a shot.

I have the latest release of Yosemite. (and in fact I started the whole endeavor with the latest public beta of El Capitan before rolling back...maybe that's part of the issue?)

by

Give this cable a try: OWC Data Doubler Mounting Kit for Mac mini 2011, 2012 & Later Models a few people have had better success with it.

by

Tim/Dan I have same issue. Did the cable swap fix the problem?

by

@westdr - Have you tried using a new cable set?

by

I ended up switching over to the OWC cable after a few months of various efforts here and there to clear up the issue to no avail. Since I switched, I've had zero read issues with the second disc. I'd recommend trying that, @westdr

by

Add a comment

Add your answer

Tim D will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 7

Past 30 Days: 44

All Time: 1,106