Model A1502 / 2.4, 2.6, or 2.8 GHz dual-core Intel processor / Released October 2013

253 Questions View all

Where is the location of the back light fuse 820-3476-a?

I recently received a Macbook Pro A1502 Retina liquid spill with logic board number 820-3476-a. Unit boots up but no back light. Does anyone know the location of the back light fuse and wled driver? Crazy thing I had it working fine however when installing the OS back light just went out. Also how many volts should I be getting on pin one?

Thanks

Block Image

Block Image

Block Image

I think this might be the location of the fuse

Answer this question I have this problem too

Is this a good question?

Score 1

Comments:

Post some top and bottom view images of your logic board with your question. Adding images to an existing question

by

Add a comment

2 Answers

Most Helpful Answer

This is all wrong. You're talking about buying replacement chips without even having a schematic or a boardview. How can you know what to replace without even knowing where to measure??? How do you know the LED driver is bad?

Get a schematic and a boardview for 820-3476, then answer the following questions before further guessing.

1) Do you have 2.7v to 3v enable signal on pin 17 of U7700?

2) Do you have 5v on pins 5 and 18 of U7700?

3) Is R7733 0 ohms?

4) Is feedback network between R7731 and R7732 functioning properly? Traces to resistors good? Resistors themselves good?

5) What voltage do you have on backlight output, pin 1 of LCD connector? 0v? 12v? 20v? 27v?

Was this answer helpful?

Score 6

Comments:

It's never the fuse on these. They are smart enough to turn off in case of a fault state.

by

I have a question concerning this board I have the same 820 3476 a and I have an amber light all the time with battery or without and no power on can you tell me where to start with this the board looks very clean I had to replace the EFI chip because the board did not have one when I bought it doesn't need flashing how to do that Thank you for your help

by

Hi

I have got 0V on pin 17 of U7700!!!

can you please lead me what should I do?

by

Add a comment

allenzabbal, you are correct. The reference designator is F7700 and it is a 3A 32V fuse in a 0603 package and the driver is U7700 and it is a LP8548B1SQ_-04 IC.

Block Image

Was this answer helpful?

Score 2

Comments:

I checked the fuse and it is not open. Can the wled driver fail without and the fuse still ok? Do you know how may volts I should get on pin 1 on the lvds connector? thanks again.

by

also where can I get the backlight package LP8548B1SQ? Would a LP8545SQ package work?

https://store.ti.com/LP8545SQENOPB-High-...

Thank you oldturkey03 for your help

by

Add a comment

Add your answer

allenzabbal will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 26

Past 30 Days: 56

All Time: 2,143