Apple's line of MacBook Pro laptops was intended for the professional and power users. The MacBook Pro line includes the MacBook Pro 13" Unibody, MacBook Pro 15", MacBook Pro 15" Unibody, MacBook Pro 17", and the MacBook Pro 17" Unibody.

13573 Questions View all

MBP Crashed during file transfer - Files Gone & can't unmount

Hi all,

Really hoping for a bit of help. I was importing files from an external WD 2Tb drive into iPhoto (iPhoto set to not actually transfer the files) and during the transfer my MBP decided to reboot. I have gone back into the folder where the files were stored and they are all gone. If i get info of the folder it just says calculating. I am a new MAC user so not that savvy with any recovery processes. Is there anything i can do to check if i can recover the files.

Also the MBP doesn't let me unmount the drive which is split into 3 partitions. I unmounts 2 of them fine but it wants me to "Force Eject" the last one...not sure what to do.

Can anyone please help?

Thanks

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

1 Answer

Most Helpful Answer

If I understand correctly the original files on the external drive are gone? OR are the original iPhoto laptop files missing?

Further which drive will not unmount the laptop or the external?

Whichever drive houses the missing files I would backup onto another drive before attempting data recovery, and recover the data to yet a different disk or partition.

You can try to repair an iPhoto directory by holding down command-option while iPhoto is launching. That will bring up a repair dialog and I would work through all the repairs one by one. After reach repair you'll have to use the key combination repeatedly to access the dialog box.

Other "fixes" that often work are to delete cache files and .plist files for problematic applications (Finder, and iPhoto) these files are stored in ~User/Library/caches and /Library/Preferences delete the files and do a reboot.

Using Disk Utility->First Aid:Repair Disk and Repair Preferences sometimes works but you can not repair the boot volume - you must do that from a different machine.

As for an external drive problem the Master Disk Directory probably needs to be rebuilt. If the disk is Mac formatted DiskWarrior or Drive Genius 3 work well for that. For data recovery I like Data Rescue 3, If it's a Windows disk I have no recommendations.

If this answer is acceptable please remember to return and mark it accepted.

I'm answering your most recent comment about alias's here because I can use paragraph breaks and text formatting which will be more readable:

1. First open iPhoto and go to Preferences, Advanced and uncheck the box "importing: copy items to the iPhoto Library"!

To have iPhoto access your photos from their current locations on your hard disk (rather than making copies of them) be sure not to move the photos from the location from which they were imported. If you move the files, your iPhoto library won’t work correctly.

2. Next Quit iPhoto

3. Mount the external drive in the finder - (it must be mounted for the alias to work). Depending on the OS (newer ones may have changes I have not worked much with Mavericks, not at all with Yosemite) you hold Option-Command( key) as you drag the picture folder from the open external volume drag that folder to the desktop then release. If it worked as expected that folder should have a small upward pointing arrow in the lower left corner of the folder icon.

4.3 I would now drag that folder (the aliased pictures folder from the desktop)'' to iPhoto icon in the Dock and let it automagically add the images (doing so will make iPhoto follow those alias's back to the external) drive without the danger of munging up your directory as the ailas's should be bytes or kilobytes not gigabytes in size.

When you open an image to edit it in iPhoto it will take time or not be instantaneous as all the gigabytes of data must finally transfer to RAM from the external via your connected port in order to display the image.

Note that if you edit one of these images in iPhoto, the edited version is saved in the iPhoto library and the original file remains untouched. So edited versions (copies on your laptop drive) will eventually have to be exported back to an external drive, then the copies deleted and iPhoto trash emptied to keep iPhoto library from growing to fill your HD.

Was this answer helpful?

Score 1

Comments:

Hi,

Sorry i explain in more detail.

The files were stored on the external HD within a specific folder i was importing into iPhoto are gone. They are not in iPhoto on the MAC and not on the external drive. Folder is still there but its empty.

The External Drive is split into 3 partitions called Archive 1, Archive 2 & Storage. When i want to disconnect the HDD it says Archive 1 can't be unmounted as it is being used by another process but it gives the option to "Force Eject" which i have not done yet.

I only have a 128Gb HDD in the MBP so store a lot of photos externally, so i was trying to create an external Library by Importing the files but not actually onto the MAC (not have them physically moved as this is an option in iPhoto). For some reason during that process the laptop rebooted and gave me this issue. I guess iPhoto creates references to all these files

I formatted the external as a windows format and use 3rd party software to make it read/write.

Should i still carry out what u suggested?

by

Power down the Mac and then disconnect the Externals. Use a Win app. to repair directory damage on the WIn drives (from a Win box). While that is going on you could try to rebuild the iPhoto directory (Back up the iPhoto library first in case of failure) What I would have done in your case is create an alias to the external folder.

by

Hi machead3,

ok will give that a go. Once all (hopefully) resolved how do i create an alias?

by

Add a comment

Add your answer

Franco will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 1

All Time: 180