1.7 GHz dual-core Intel Processor (Turbo Boost up to 2.6 GHz) with 3 MB shared L3 cache

80 Questions View all

magsafe powering computer but not charging the battery

After mild liquid (cat pee) damage near the left (charger, USB, headphone jack) side, magsafe light will not come on.

The computer shows the charger icon with no "lightning bolt" and the battery says 0%. It appears to be getting power from the charger, since it has not died even though it's been a couple of months since this happened.

The USB and headphone jack work.

At the genius bar, they opened it but would not fix it once they saw it was gross liquid damage. They did not say where the damage was (or I didn't hear it).

Otherwise the computer works perfectly. Do I need to replace the left I/O board? (the charger works on a different mac). Any guidance would be much appreciated.

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

I am interested to hear what you came up with. I have the same issue that you're having. I didn't have any water damage though. The system information still lists my battery condition as normal. I ran the apple diagnostics, did a SMC reset, everything, and still no light.

That said I have yet to try another charger. Did you get a replacement battery? Did that fix it?

by

Add a comment

1 Answer

Chosen Solution

That would be a good place to start... you may also need a new battery.

Carefully cleaning the logic board of any corrosion would also be wise. as corrosion worsens over time, and bridging may occur.

If this answer is acceptable please remember to return and mark it.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Swerve will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 3

All Time: 305