MacBook Pro powers on, doesn't do RAM check, won't boot

Was using a rarely used MBP to restore my Mothers iPhone today, the iPhone failed to restore and went in to DFU mode. iTunes then sat waiting for the iPhone, so I thought best to reboot the MBP and start fresh.

White light came on, fans and HDD started spinning, nothing else.

It's a 2008 A1260 2.5Ghz MBP, used as an iTunes server and nothing else. Sleeps and wakes, never turned off, never did anything strenuous, didn't get overly hot.

Tried PRAM, SMC, taking RAM out, different RAM, booting from a disc (via USB, internal one died and think I threw it out)

Taking the RAM out it doesn't make a sound.

No signal is output via the DVI.

Letting it sit on until the battery died did nothing.

Unplugging HDD/Screen/CMOS Battery does nothing.

Any ideas? Despite it being an 8600M model, I don't think it's an issue with that. Seems like something failed that's only used in boot up, which is why it worked fine until it tried to reboot itself.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

Remove mains and battery overnight. Boot with no peripherals - do a safe boot. Run DFA repair permissions.

If this answer is acceptable please remember to return and mark it.

Was this answer helpful?

Score 1

Comments:

How do I do a safe boot? I'll leave it disconnected from power for a couple days and come back to it.

by

Hold shift key down until you see the sundial then let up.

by

Add a comment

This machine will rarely boot without a good battery with at least a 20% charge. So get the battery charged first. Next it has the infamous GeForce 8600M GT video chip. I had a machine in for the same symptoms just last week. I put in a new battery and it fired right up. I then shut it down and tried to reboot and the chip failed right there. There are places that are now doing reworks on these chips on eBay, I just got one in from them today and it ran me $150 plus shipping but took 5 weeks.

Was this answer helpful?

Score 1

Comments:

Left it running overnight to warm everything up and fully charge the battery, still nothing.

by

Press the battery test button and tell us what is says. Hook it up to an external monitor and see if it is generating any video signal.

by

Add a comment

Add your answer

Matthew Dear will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 515