PowerBook Won't Charge Battery

I have a 15" Aluminum PowerBook 1.5 GHz PowerPC G4 running OSX 10.5.8

Recently the battery has stopped charging. In the menu bar I have a "not charging" next to the battery icon. I checked the battery with Coconut and it says the battery has a 79% capacity. I tried another batter from a friend since I thought that was the issue, but his battery was only 44% capacity according to Coconut. I tried his battery but it was also dead and didn't charge on my PowerBook at all.

I read about the DC board, and I'm hoping to get a new MacBook Pro when the Haswell chipset comes out, hopefully soon. I hate to spend $100 on a part for this laptop but is there any other option any one might see. I also read about resetting the PMU, which I've never heard of. Is this like zapping the pram? I remember that from my 8500 days.

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Chosen Solution

Resetting will not "fix" a faulty DC in board. These go bad over time from wear and tear to the solder joints. If your's has never been replaced it's due. You might be able to prolong the life if you see under a magnifier that the solder is cracked or if the contacts appear lose. Soldering logic board/computer components is and advance DIY. You need special tools, solder and lots of practice.

It might be wiser to see if a local electronics repair shop can resolder the parts if they appear lose. If that fails you can still put in a replacement DC in board.

If this Answer is helpful please remember to return and mark it Accepted.

Was this answer helpful?

Score 2

Comments:

So I just finished tearing down my PowerBook G4 and replaced the DC / Sound Board. I got one on Ebay for $40. I also replaced the right side USB board since that had stopped working some time ago. Well, the plug in adapter is still green and the battery monitor says (Not Charging) Coconut still says the same stats about the capacity.

This is so frustrating, especially since the tear down was no easy feat.

Does anyone have any other ideas what might be wrong? I tried using another battery from a friend to no avail.

by

Add a comment
Most Helpful Answer

Try your battery in the friends machine to see if it is OK. Next replace the battery connector. Check your machine to see if this is the right one: G4 Aluminum 15" 1/1.25/1.33/1.5 GHz Battery Connector

Was this answer helpful?

Score 3
Add a comment

Add your answer

Patrick will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 5

Past 30 Days: 24

All Time: 832