difficulties to switch on my iMac when it was cold

Hello,

As my problem is quiet the same, I don't know if I have to open a new topic?

For sometime, I had more and more difficulties to switch on my iMac when it was cold (after a night or more, I had to reboot it up to 30 time to really wake it up!), and a lot of sudden "sleep mode" with anything to do but reboot it…

Few days ago, finally refuse to boot:

no gray screen, no sound, just the light on in the right corner… and a new weird sound when it tries to boot!

After trying everything I could (reset PMU, PRAM, change the ram etc etc), I decided to open it.

I cleaned it of all the dust accumulated in 2 years (when I changed the original HD) and checked everything I could, but I didn't notice anything suspect.

The 1st LED is lit when the cable is connected,and when I push the power button, the 2 and 3 are lighting up too (and stay lit), and that's all.

The fans are on, everything else seems to light on, but there is still the same unusual noise and the display stay black and the HD don't seem to start up.

Only the white light (on the right beneath the display) stay lit.

I strongly suspect the power supply, but before buying a new one, I'd like to know what you think of it : )

If some has a clue or an advice, it would be great!

And sorry for my english… I'm a French ;-)

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

I do not think this is a power supply issue. Some troubleshooting is necessary. The 4th LED indicates logic board -> display operation.

Try connecting to an external monitor. If that works ok the problem is in the onboard display chain... cable (most likely) inverter or LCD.

If this Answer is helpful please remember to return and mark it Accepted.

Was this answer helpful?

Score 1
Add a comment

Add your answer

Thierry will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 529