Model A1286. Released February 2011 / 2.0, 2.2, or 2.3 GHz Quad-core Intel Core i7 Processor

389 Questions View all

SSD on primary not working

So, I've got a early 2011 Macbook Pro (8.1) and attempted to replace my superdrive by the 320 HDD that came along and put a 128Gb OWC 6G SSD in the primary slot.

I installed the SSD in the primary bay and the original HDD in the optical bay using the data doubler. After that I booted in the old drive and attempted to partition the SSD. What happens is that, after a couple of minutes, it failures to recognize the SSD.

The partitioning process stops (w/ the message disk object invalid or unable to serialize) and the SSD drive doesn't show up anymore in the left size of the Disk Utility. If I reboot, the same happens (initially recognized, then disappears). In the system report it shows up as unknown SATA device.

I reseted PRAM and in the system report the SSD was recognized (instead as unknown, as I previously mentioned), so I tried to use the Disk Utility again. This time the S.M.A.R.T. status was ok and the drive was marked as read/write, so I thought maybe this time it would work.

I selected one partition GUID and applied. The progress bar started and the message "Unmounting device" was shown for a while, until the process stopped and the message "couldn't open device" was shown.

The SSD was still being shown on the left side of the screen, but the S.M.A.R.T. status changed to Not Supported. I tried once again and the results were the same, except this time the message was "Disk object invalid or unable to serialize". I closed the Disk Utility and opened again and the SSD was gone. In the system report the SATA device is shown now as unknown device.

The data doubler is working fine. The HDD kept running on the optical bay all the time, no issues so far.

So I bought an external enclosure and managed to partition and install a fresh OSX install through the USB port. Then I inserted the SSD back in the primary slot and tried to boot again, but received a prohibitory sign during the system startup.

So is it possible that the SATA cable or controller was damaged during the installation? What you guys would recommed me to do next? Replace the SATA cable?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

SSD standard for S.M.A.R.T attributes are very recent - so that's probably why it is reporting so strangely. It is possible the cable/connector was damaged since in an external case the drive seems to work without problems.

The cable would be the cheapest-easiest fix to try. If that doesn't work it might be a good idea to have a professional look at the connector (repairing logic board components is a very advanced DIY project which takes lots of practice, & special tools).

If this Answer is helpful please remember to return and mark it Accepted.

Was this answer helpful?

Score 1

Comments:

Thanks man. I ordered a replacement cable... Fingers crossed now!

by

Add a comment

Add your answer

Denys Braga Peres will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 6

Past 30 Days: 34

All Time: 1,188