Late 2011 model, A1278 / 2.4 GHz i5 or 2.8 GHz i7 processor.

386 Questions View all

No Superdrive in System Information/Report

My Superdrive became unresponsive. Wouldn't Burn or eject disk (although one will load, then get stuck).

I see the System Report says I have no DVD drive.

I tried swapping disk. No change.

If it's not the cable (next) could it be the drivers? I hope it's not the motherboard.

Thanks

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Comments:

new cable made no difference.

Help please!

by

Add a comment
Deck the Halls
With tools and Fix Kits

1 Answer

Chosen Solution

Have you tried re-installing the OS yet? If not give that a try otherwise, I don't have very good news here, sorry ;-{

Sounds like the platform controller hub has a problem or the ribbon connector on the logic board is bad. In either case unless you have the skills & tools to work with SMD technology its best to replace the logic board or find someone who can repair the logic board.

You could try running AHT to see if it reports anything.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Kevin Krooss will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 1

All Time: 100