Skip to main content

Mid 2009 Model A1278 / 2.26 or 2.53 GHz Core 2 Duo processor EMC 2326

735 Questions View all

Mother Board : S.O.S.

I tried an impossible repair for a customer

MacBook Pro Mid 2009

After updating interrupted, does not start. The motherboard is SOS: 3 long beeps, 3 short and 3 long

I tried everything I believe:

Reinstalling Firmware 1.7 for this model, the CD is rejected (I burned CD 3: the same)

Replacing RAM: Nothing

Replaced the battery, disconnected the battery ...

Unable to start external hard disk or DVD with install., The keyboard is not functional.

If someone in another track, I'm interested, but obviously replace the motherboard!

Firmware Pb, pb Burning CDs or DVDs

Big thank you in advance

Answered! View the answer I have this problem too

Is this a good question?

Score -1


What was being updated here: the firmware, OS or hardware?


Mac Os update only


Add a comment

2 Answers

Chosen Solution

From what I understand the logic board may be pooched. I know of no way to DIY correct this... a logic board repair business might be able to replace/re-flash the firmware chip... but the shade tree fix (if the reload failed) would be to replace the logic board.

If this Answer is helpful please remember to return and mark it Accepted.

Was this answer helpful?

Score 2


I think unfortunately you're right :(


Firmware/EFI chip changed and it works fine, Thanks


Add a comment

I don't remember seeing the OS installer do a firmware upgrade in the update process. So I'm not sure why your system bit the big one here when you were only upgrading the OS. What OS-X are you installing?

Review this Apple TN on the Beep Codes iMac (Mid 2007) and later models: About startup tones By this your Firmware is in the process of being updated. So it is likely looking for the image file on the HD or DVD you where installing the OS from. Put everything back together and as you were doing the upgrade and see if you can get the process to complete.

Was this answer helpful?

Score 0


Yea sometimes the firmware seems to take unusually long, and, you must let it restart (possibly more than once) on its own until it stops at the login/desktop (however you have it set up).


Mikhrych - Can you give us details on what did it. Did you just let the process complete or did you have to physically swap out the EEPROM after loading it with the firmware.


Add a comment

Add your answer

Mikhrych will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 732