Model A1286. Released February 2011 / 2.0, 2.2, or 2.3 GHz Quad-core Intel Core i7 Processor

546 Questions View all

MBP Optical Drive SSD Replacement: Error -36

I'm trying to replace the optical drive in my MacBook Pro with a 500GB SSD (Crucial M4 ( plus a generic hard drive caddy ( Unfortunately, once I install the drive, whenever I try to write a file larger than ~200KB to it, I get the error "The Finder can't complete the operation because some data in "[file name]" can't be read or written. (Error code -36)".* I can read data from it normally.

If I put the SSD in the external enclosure I bought for the SuperDrive, it works perfectly, reading and writing any size of file.

If I put the original SuperDrive back in my computer, it can play DVDs just fine, and I have successfully burned a CD at a speed of ~25x.

Any thoughts? I thought it might be the cable between the drive and the motherboard, but I can't see any damage, and being able to write CDs would seem to rule that out.


Rob W

  • At one point I got "Error -50" whenever I tried reading or writing, but after checking all the cables, it stabilized on "Error -36" when writing non-trivially-sized files.

Error -36 reference:

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

Free shipping on all orders over $100 or containing a Pro Tech Toolkit!

Browse Our Store

Ever fixed something? That’s Genius.

Share your repair story with #ImAGenius

We Are All Geniuses

Share your repair story with #ImAGenius

2 Answers

Chosen Solution

I believe it's the caddy. I took a look at the web site. No SATA type/version information was available - that is crucial information. If the caddy can't support the speed of the SD card, and/or the cards automagically detecting transfer interface can't figure out what SATA to use you'll get the read/write errors (file corruption errors) that you are seeing.

Talk with the vendor to find out the cards speed or interface. Because the card works in a different caddy (case) I think the problem is not the card, The still working optical drive rules out your Logic board & cable.

The remaining variable is the caddy It might be automagic detecting too and now the two automagically detecting connectors are fighting over which speed to use, and can't reach a workable solution.

If this Answer is helpful please remember to return and mark it Accepted.

Was this answer helpful?

Score 1


For clarity, I put the whole disk/caddy assembly in the external CD drive enclosure and it worked fine. However, I see your point about potential conflicting automagical speed detection. I'll look into it- hopefully there's a fix besides buying a different caddy.



Yep, that seems to have been the issue. I just installed the drive using an OWC caddy, and it's working just fine. Thanks!


Add a comment

I have the same problem using the OWC data doubler. I can read from the disk but i cannot write mostly. Sometimes I can write, but I almost always receive 'Error -36: Finder cannot complete the operation because some files cannot be read or written'.

Any other suggestion? Thanks!

Was this answer helpful?

Score 0


If it's not the drive or caddy that leaves the cable/connector.


Add a comment

Add your answer

Rob W will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 3

Past 30 Days: 10

All Time: 1,096