Skip to main content

The PowerMac G5 is a desktop computer first produced in 2003 by the Apple Corporation. This guide will review the repair process of an Apple PowerMac G5 model number A1047 EMC 2061 from 2004. It was discontinued in 2006 as part of the Intel switch first to developers then consumers.

197 Questions View all

AHT - errorcode / what does it mean?

Computer is G5/2,5 GHz - late 2004 (SCI-x slots) - on two of the slots is audio-card + an serial ATA card.

Shall I remove them be4 test by AHT?

The errorcode become under the process when AHT is starting, after the choise of langues,:


invalid memory access at %SRR0 : 00000000 . 010e9ab8 %SRR1 : 10000000 . 00003030

One problem is that i dont have orginal CD, and the AHT is from a newer mac G5, late 2005 (with SCI express slots).

Ive tried that AHT on a older G5/1.8 from 2004 june and then AHT starts. And i also can run the test successfully.

The G5 2,5GHz (2004) is indicating Hi temperature on "memory heatsink" when testing with temperatur monitor - and fan runs up and down all the time.

Ive tried to take all memory away- execpt on par, and change memory on the slots to - thre error code result is the same.

When testing with Techtool pro 4.6.1 - No error.

PLEASE advise mee - what to do?

Answered! View the answer I have this problem too

Is this a good question?

Score 0

Sorry - did find out the reason of errorcodes by myselves.

After removing the audio and sata-card i could start the hardware test. And no problems where detected on the short test, so now is the long version of test running.

My problem is still that fan is running up and down, because of temperatur of 79° celsius in the memory heat sink.

WHERE IS THE heat sinkt detector placed - anyone who knows??


invalid memory access at problem ?


Add a comment

3 Answers

Chosen Solution

Does this help? I have read reports that there is a heat-sink on rear side of logic board rear may cause heat problems. Remove/clean and reapplying compound may lower the temps.

Was this answer helpful?

Score 2

1 Comment:

Concur--I've read similar reports. Ralph +


Add a comment

The reason is a bug, implementet by Apple in system 10.4.4, not fixed.

Read my "bhu bhu Apple - thread".

I beleive it is a "bug" by purpose, to keep temperature down, so not the liquid do expansion - with leak of the cooling system as an result.

Obviously the leak normal is in the plastic material in the pump area, wich indicate pressure-reason behind it.

Was this answer helpful?

Score 0
Add a comment

The invalid memory access error is usually do to a problem with RAM. Either the RAM chip has a problem or the main board is having a problem communicating with the RAM. Either way, that RAM chip needs to be removed/replaced.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Goran will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 4

All Time: 2,768