Model A1237 or A1304 / 1.6, 1.8, 1.86, or 2.13 GHz Core 2 Duo processor

351 Questions View all

New HDD wont show in System Profiler

My Hard Disk died.

So I've bought a Mach Xtreme Technology PATA 1.8" SSD to replace it.

(Part Number MXSSD1MNANOZ-120G)

Ive installed it as per the iFixitYourself tutorial

http://www.youtube.com/watch?v=PnV7mHS7Q...

I am doing a fresh install using my ligitimate Snow Leopard DVD on my USB disk.

The USB is installing but NOT finding a hard disk to install to.

When I use System Profiler is does not find the Disk under Hardware>ATA (or even Serial-ATA)

I've double checked the connections.

The genuine Mac SSDs are ridiculously expensive. The drive I've installed is the same form factor.

Is there something I have missed?

Answered! View the answer I have this problem too

Is this a good question?

Score 0
Add a comment

1 Answer

Chosen Solution

OK - Think I've fixed it. Although the form casing etc look similar. The Zif connector on the Mach SSD is the other way around- i.e. Pin 1 of the ribbon cable is at the other end.

So I had to turn the whole SSD the other way up.

This in turn caused the disk to be about 2mm out of polace which meant I had to cut away part of the rubber vibration housing. (I fugure there is no vibration on an SSD so that should be OK.

Problem Solved.

Was this answer helpful?

Score 1
Add a comment

Add your answer

graham will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 2

All Time: 162