1.83 GHz Core Duo or 1.83, 2, or 2.16 GHz Core 2 Duo A1208 (EMC 2104/2110/2114/2124)

252 Questions View all

iMac Late 2006 won't power up

Installed SSD recently and everything worked for a week. This morning, I was unable to power on the machine. Disassembled the machine and peeled back the EMI cover. The first LED light came on as soon as connected to the power source and both fans jittered. When the power button is pressed, the second LED came on and stayed on. However, nothing happens. The third LED light never come on. Kept holding down the power button and the second LED went off. Any advice would be greatly appreciated.

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment
Deck the Halls
With tools and Fix Kits

2 Answers

Chosen Solution

Sounds like a bad power supply. Also examine the 24 capacitors for swelling and/or corrosion.

Was this answer helpful?

Score 1

Comments:

Thanks mayer. Will remove the power supply and look at it today. The fact that the first LED stays on solid when iMac is connected to the power source does not necessary indicate that the power supply is good?

by

Almost all the power supplies 20 to 1 have had the the first green light on. All that indicates is that there is trickle power getting to the unit.

by

Removed the power supply and examined it; noted 5 capacitors on the board. No swellings or corrosions were noted. Is there ways to test the PS to determine if it is good or bad?

by

Add a comment

This is an all in one desktop unit.

Was this answer helpful?

Score 0

Comments:

and? Tell us something we didn't know.

by

Add a comment

Add your answer

Shane will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 2

Past 30 Days: 4

All Time: 562