Laptop constantly goes into sleep mode

Hi! I've got a 12" 1.33GHZ G4 which boots up fine, but then constantly goes into sleep mode. You can wake it up, but within seconds it goes back to sleep. Occasionally it works longer, but without fail it ends up asleep again, and it is therefore unusable. Thinking it was a reed switch issue, I replaced the entire screen assembly/cabling twice with known good units, and both times it had the same result. I've also reset the PRAM and PMU, removed the RAM and battery, tried a different topcase, etc. This model does not have a magnet on the right side by the optical drive, so it's not that. It seems to be something with the board. Anyone have ideas? Thanks!

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment
Deck the Halls
With tools and Fix Kits

2 Answers

Chosen Solution

John, the reed switch board on the 12" 1.33 is glued to the top of the optical drive and the magnet is screwed in the display right side (center of the display bezel). Disconnect the reed switch cable connector located near the trackpad connector and boot the iBook. If the machine works normally then replace the reed switch board. If the iBook was liquid spilled then the logic board could also be the culprit.

iBook G4 12" 1.33 GHz Reed Switch Board Replacement

iBook G4 12" 1.33 GHz Reed Switch Board

Was this answer helpful?

Score 3

Comments:

Lemerise, thank you so much -- that was the problem! You've saved my iBook! :-) I pulled the reed switch cable, and it now works. Oddly, I plugged in a different one, and it had the same problem, but I'm happy to just leave it out and have a laptop that doesn't fall asleep when the lid closes. It's funny, I'd always assumed the reed switch was something to do with Bluetooth, since this is the only 12" with Bluetooth. Now the problem with the machine is that the screen stays black until the OS is almost completely booted (i.e. you don't see the Apple icon phase), so I don't know what that's about...I tried another screen with no change. But hey, at least it works. Thanks again!

by

On the 12" 1.33 model the bluethoot hardware is integrated in the airport card and the two antennas cables goes from the airport/bluethoot card to the display via the iBook hinge. There are other iBook G4 models that use bluethoot (the 1.2Ghz I think). On these models the small bluethoot board is screwed on the metal frame near the top case cable socket and connects in a socket near by.

Try to boot the iBook from another source (without ram installed) to check if you'll have video onscreen when the boot process begins. If you get the same black screen then it could be a bios issue. Maybe there's a firmware update that could be applied to the iBook, I don't know. Anyway if the iBook boots and runs stable then the logic board is probably OK.

by

I tried a third reed switch, and that one worked fine, and I tried another screen assembly, and somehow that resolved the "black screen until OS has booted" issue, so the laptop is working fine now. I guess it goes to show that it never hurts to have tons of spare parts around. Thanks again!

by

Add a comment

I have the same problem with an iBook G4 1.42 Ghz, i recently unmoutes it for a problem i had with de optical drive. Ever since, it constantly goes into sleep mode and when i wake it up the screen shows the desktop for 1 sec and then goes back in sleep mode.

I've read about a sleep magnet, do you think it's this magnet the problem and where is it located precisely?

Was this answer helpful?

Score 0
Add a comment

Add your answer

rdklinc will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 0

All Time: 3,451